Problema con la paginacion, no cambia de pagina

Inicio Foros WordPress Themes y Diseño Problema con la paginacion, no cambia de pagina

Etiquetado: , ,

Este debate contiene 10 respuestas, tiene 4 mensajes y lo actualizó  imported_jaume hace 9 años, 1 mes.

  • Autor
    Publicaciones
  • #12949

    imported_ACALU
    Participante

    <p>Hola,</p>
    <p>Estoy intentando poner al final de la plantilla, la paginacion del blog, con el numero de paginas que hay publicadas. He insertado el codigo en el index.php:</p>
    <p>

    Quote:
    &lt;?php<br />
    if(function_exists(‘pagination’))<br />
    pagination(2,array(&quot;Anterior&quot;,&quot;Siguiente&quot;));<br />
    ?&gt;

    </p>
    <p>Pero al darle a la siguiente pagina no pasa a esta y vuelve a salir la ultima publicada. La plantilla base no traia por defecto la opcion de paginacion.</p>
    <p>Si alguien me puede echar una mano se lo agradezco.</p>
    <p>Informacion del blog:</p>
    <p>- Version WP: 2.7.1<br />
    – URL blog: acalu.es<br />
    – Theme: Fontella (granimpetu.com/fontella)<br />
    – Plugins activos: Akismet, FeedBurner FeedSmith, Google Analytics for WordPress, WordPress.com Stats, WordPress Reports, All in One SEO Pack, WordPress Gravatars, *WP-Digg Style Paginator, Subscribe To Comments.<br />
    – He modificado el theme para dejarlo con 1 columna en vez de 2, y he reajustado el pie del blog.<br />
    – Mi nivel de html, php o css es muy bajo.</p>
    <p>Un saludo.
    </p>

  • #28387

    quicoto
    Participante

    Has probado con este fantástico plugin ? http://wordpress.org/extend/plugins/wp-pagenavi/

    saludos

  • #28388

    sagito3x
    Participante

    ACALU dijo:
    Hola,

    Estoy intentando poner al final de la plantilla, la paginacion del blog, con el numero de paginas que hay publicadas. He insertado el codigo en el index.php:

    [quote]<?php
    if(function_exists(‘pagination’))
    pagination(2,array("Anterior","Siguiente"));
    ?>[/quote]

    Pero al darle a la siguiente pagina no pasa a esta y vuelve a salir la ultima publicada. La plantilla base no traia por defecto la opcion de paginacion.

    Si alguien me puede echar una mano se lo agradezco.

    [u]Informacion del blog:[/u]

    – Version WP: 2.7.1
    – URL blog: acalu.es
    – Theme: Fontella (granimpetu.com/fontella)
    – Plugins activos: Akismet, FeedBurner FeedSmith, Google Analytics for WordPress, WordPress.com Stats, WordPress Reports, All in One SEO Pack, WordPress Gravatars, *WP-Digg Style Paginator, Subscribe To Comments.
    – He modificado el theme para dejarlo con 1 columna en vez de 2, y he reajustado el pie del blog.
    – Mi nivel de html, php o css es muy bajo.

    Un saludo.

    Tambien te lo recomiendo es muy bueno y facil de usar. Ademas para su modificacion es muy sencilla.

  • #28391

    imported_ACALU
    Participante

    Me he descargado el plugin y lo he instalado (antes he desactivado el plugin *WP-Digg Style Paginator y he borrado el codigo anterior que tenia puesto en index.php). Pero lo he probado sin insertar ningun codigo en la anterior pagina y no me funciona, y luego con este que me he encontrado en una web, pero nada, ahora no sale nada:

    [quote]<?php if(function_exists(’wp_pagenavi’)) { wp_pagenavi(); } ?>[/quote]

    Y la verdad es que parece que esta mejor que el que tenia antes, porque puedes modificar algunas opciones en el panel de control. ¿Que puedo hacer para echarlo a andar?

  • #28392

    imported_ACALU
    Participante

    . (borro este mensaje porque por error mande el anterior 2 veces al darme un error).

  • #28400

    sagito3x
    Participante

    haber te pongo el code que estoy usando tambien en index.php
    [code]
    despues de:
    <?php endwhile; ?>
    colocas lo siguiente:

    <div class="navigation">
    <div class="center"><?php if(function_exists(‘wp_pagenavi’)) { wp_pagenavi(); } ?></div>
    </div>

    prueba con esto haber [/code]

  • #28403

    imported_ACALU
    Participante

    Yo es que no tengo el 1º codigo que comentas. Pego por aqui todo el index.php y donde estoy colocando el 2º codigo que me das (con el cual ahora si sale el texto, aunque le falta una linea de abajo, pero no funciona).

    [quote]<?php get_header(); ?>

    <div id="indexwrapper">

    <div id="presentation">

    <div id="logo">

    <div class="logobg"></div> <!–Puedes poner aqui tu logo o tu foto–>

    </div>

    <div id="lastpost">

    <?php $lastposts = get_posts(‘numberposts=5’);
    foreach($lastposts as $post) :
    setup_postdata($post);
    $id_hardware = $post->ID;
    ?> <!–Esto llama a la ultima entrada – Cambia el numero 1 para obtener mas–>

    <h1 class="post">" rel="bookmark" title="<?php the_title() ?>"><?php the_title(); ?></h1>

    <?php the_content("Continuar leyendo…"." »"); ?>

    <div class="feedback">

    <div class="date"> <!–Calendario–>
    <div class="year"><?php the_time(‘Y’); ?></div>
    <div class="day"><?php the_time(‘j’); ?></div>
    <div class="month"><?php the_time(‘M’); ?></div>
    </div>

    • Publicado por <?php the_author(”) ?> a las <?php the_time(‘h:i a’) ?> <?php edit_post_link(‘Edit’, ‘ — ‘, ”); ?>
    • <?php comments_popup_link(‘Sin comentarios’, ‘1 Comentario’, ‘% Comentarios’); ?>
    • Guardado en: <?php the_category(‘, ‘) ?>

    </div>

    <?php endforeach; ?>

    </div>

    <div class="navigation">
    <div class="center"><?php if(function_exists(‘wp_pagenavi’)) { wp_pagenavi(); } ?></div>
    </div>

    </div>

    </div>

    <?php get_footer(); ?>[/quote]

  • #28408

    sagito3x
    Participante

    entonces el codigo
    [code]<div class="navigation">
    <div class="center"><?php if(function_exists(‘wp_pagenavi’)) { wp_pagenavi(); } ?></div>
    </div>[/code]

    ponlo antes de
    [code]<?php get_footer(); ?>[/code]

  • #28470

    imported_ACALU
    Participante

    Ya lo probe, pero nada, sigue sin funcionar 🙁

    Un saludo.

  • #28471

    imported_jaume
    Participante

    Pues yo tengo el mismo problema o similar,ya que no me aparece la barra de [b]Pagenavi[/b],de las páginas en el footer.
    En otra plantilla([b]inove[/b])funcionaba,pero en esta([b]Mandigo[/b])no.

  • #28474

    imported_jaume
    Participante

    Pues ya está arreglado.
    Sólo faltaba añadir ésta línea al [b]footer.php[/b]:
    [b]<?php if(function_exists(‘wp_pagenavi’)) { wp_pagenavi(); } ?> [/b]

    Perdón por romper vuestro hilo… 😕

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest