Problema con mi tema y wp-pagenavi

Inicio Foros WordPress Themes y Diseño Problema con mi tema y wp-pagenavi

Etiquetado: ,

Este debate contiene 13 respuestas, tiene 3 mensajes y lo actualizó  23r9i0 hace 9 años, 11 meses.

  • Autor
    Publicaciones
  • #11654

    23r9i0
    Participante

    <p>Hola mirar acabo de darme cuenta que mi plantilla no funciona bien con wp-pagenavi he probado el tema predeterminado para saber si era culpa de otra cosa pero no definitivamente es mi tema.<br />
    Yo he colocado el wp-pagenavi en el footer de la siguiente manera:</p>
    <pre><code>
    &lt;div id="footer"&gt;
    &lt;div class="navigation"&gt;
    &lt;?php if(function_exists(‘wp_pagenavi’)) : ?&gt;
    &lt;?php wp_pagenavi() ?&gt;
    &lt;?php else : ?&gt;
    &lt;div class="alignleft"&gt;
    &lt;?php next_posts_link(__(‘&laquo; Older Entries’, ‘sininen’)) ?&gt;
    &lt;/div&gt;
    &lt;div class="alignright"&gt;
    &lt;?php previous_posts_link(__(‘Newer Entries &raquo;’, ‘sininen’)) ?&gt;
    &lt;/div&gt;
    &lt;?php endif; ?&gt;
    &lt;/div&gt;
    …</code></pre>
    <p>Pero no me detecta bien las páginas, si coloco este codigo en el index.php entre<br />

    Code:
    <br />
    aqui se acababa el loop de las entradas<br />
    &lt;?php endwhile; ?&gt;<br />
    Aqui he probado el codigo y funciona bien<br />
    &lt;?php else : ?&gt;<br />
    aqui empieza el codigo cuando no se encuentra la página

    </p>
    <p>Sabeis que le puede pasar?<br />
    En la pagina dicen que se puede poner en el footer.php<br />
    Saludos<br />
    Aqui esta mi blog para que lo veais
    </p>

  • #24541

    imported_Mno4K
    Participante

    Por lo que ví en tu sitio las páginas funcionan bien, que es lo que no te detecta?

  • #24542

    23r9i0
    Participante

    Hola Mno4k Pasate otra vez por el blog y veras lo que te digo.
    He colocado el codigo entre[code]
    <?php endwhile; ?>
    Aqui he probado el codigo y funciona bien
    <?php else : ?>
    [/code]
    Para que veas lo que te digo.
    Saludos!!

  • #24548

    imported_Fernando
    Participante

    Otra opción es ponerlo al principio del todo del footer, antes de cualquier otra cosa, suele funcionar bien así en casi cualquier theme.

  • #24553

    23r9i0
    Participante

    Hola fernando No me funciona!!

  • #24554

    imported_Fernando
    Participante

    Cachis 🙁

    Pues ponlo al final del content, como lo tienes ahora duplicado, ahí queda bien, lo quitas del footer y punto.

  • #24556

    23r9i0
    Participante

    Si pero quiero verlo fijo en el footer porque por ejemplo en el archivo o resultados de busqueda como tengo el excerpt personalizado las entradas quedan muy pequeñas y en medio del blog ves la barra y no me gusta mucho. Se supone que deberia ir bien o por lo menos eso es lo que dicen en la pagina del plugin que lo coloquemos en el footer.

  • #24558

    imported_Fernando
    Participante

    Si, te entiendo, pero cada theme es un mundo. Espera que hago unos experimentos 🙂

  • #24561

    imported_Fernando
    Participante

    Es curioso, en el código en el footer no te coge todo el código de la class wp-pagenavi, no pillo aún porqué, estoy haciendo pruebas con el firebug a ver

  • #24563

    23r9i0
    Participante

    Merci!! mirare eso del firebug nunca lo he usado y he oido hablar de el.
    Te puedes bajar el theme desde mi blog para probarlo localmente, si quieres el que uso es el sininen3.
    Nos vemos.

  • #24566

    imported_Mno4K
    Participante

    También hice algúnas pruebas, pero no hay caso. Tienes el footer habilitado para widgets? Puedo estar inventando, pero me parece que eso puede dar problemas con el pagenavi

  • #24569

    imported_Fernando
    Participante

    No hace falta bajarse el theme, con el Firebug puedo hacer cambios y ver como va quedando tu página al instante, como si la estuviera modificando realmente 😉

    Y si, es raro, mira que le he puesto divs, modificado los actuales, incluso he probado a modificar el CSS del div navigation (parece que es el que interfiere), pero no hay manera, no sale como debiera en el footer, es curioso.

  • #24575

    23r9i0
    Participante

    Buenos Dias!!
    He estado tocando el index.php para encontrar una solución y al cambiar el [code] <?php get_sidebar(); ?>[/code] de lugar lo curioso es que funciona a la perfección pero el sidebar no, creo que seguiré investigando por hay, ya que si elimino la barra funciona, ahora tengo que averiguar como hacerlo.
    Si se os ocurre algo estoy abierto a ideas!!
    Saludos!

  • #24580

    23r9i0
    Participante

    Bueno después de un café y cigarrillo he vuelto a mirarlo y he empezado a descartar cosas y resulta que el código que usaba para mostrar las ultimas entradas era el causante no se porque ya que no se php y normalmente voy haciendo las cosas por error.
    Me acorde que antes use el tema inove y tenia un código para mostrar las entradas y lo he usado para hacerlo y este no entra en conflicto con el plugin.
    Gracias a los dos! y a ti Mno4k lo del widget me hizo pensar que era culpa del código que tenia .

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido