Problema con tema

Inicio Foros WordPress Themes y Diseño Problema con tema

Etiquetado: ,

Este debate contiene 5 respuestas, tiene 3 mensajes y lo actualizó  ziuncol hace 6 años, 2 meses.

  • Autor
    Publicaciones
  • #62339

    ziuncol
    Participante

    Hola a todos, yo tengo mi blog el localhost/wordpress y accedo a través del navegador y todo perfecto (el tema se carga correcatmente con su hoja de estilo css y todo eso) pero si cambio el nombre de la carpeta (por ejemplo de wordpress a wp) al acceder el tema (mediante localhost/wp) se carga sin la hoja de estilo y sin ningún tipo de estructura (vamos que no se carga el archivo css) ¿cúal puede ser el problema?

    PD: Ya he limpiado la cache del navegador.

    Un saludo.

  • #62340

    LGrusin
    Miembro

    Pues que eso no lo puedes hacer, WordPress guarda información de la URL en la base de datos. Si cambias el nombre de la carpeta tambien debes hacer los cambios en la base de datos.

    Un saludo

  • #62341

    almendron
    Participante

    No se puede cambiar el nombre de la carpeta sin más ya que es necesario seguir un proceso determinado. Ni siquiera es suficiente con cambiar las rutas en las opciones de wordpress.
    Si solo estás haciendo pruebas, no cambies el nombre de la carpeta. Personaliza el tema a tu gusto y, una vez hayas acabado, subes el tema al servidor.

  • #62384

    ziuncol
    Participante

    Muchisimas gracias a los dos! LGrusin eres un crack!!!!! Ya está solucionado.

    SOLUCIÓN: Editar la tabla “wp_options” y dentro de ella el campo “siteurl” (desde phpmyadmin) poniendo la ruta deseada

    MUCHAS GRACIAS.

  • #62393

    LGrusin
    Miembro

    Todavía hay más referencias en más tablas. Exporta la base de datos y mira con un editor de texto para que compruebes cuantas ULRs con localhost/wordpress te aparecen.

    Por ejemplo, si tenías publicados posts todavían quedarán URLs con localhost/wordpress
    Verás que cuando pinches en uno de ellos te mandará a la URL anterior con wordpress

    Un saludo

  • #62427

    ziuncol
    Participante

    Muy cierto, ya está solucionado, he exportado la base de datos entera en un archivo xml (he eliminado la base de datos por completo para que al importar no haya duplicaciones), lo he editado con el bloc de notas de windows sustituyendo la anterior carpeta por la nueva he importado ese mismo archivo y parece que toda va correctamente.

    Saludos.

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest