Problema con the_excerpt

Inicio Foros WordPress Themes y Diseño Problema con the_excerpt

Etiquetado: , ,

Este debate contiene 3 respuestas, tiene 2 mensajes y lo actualizó  imported_study hace 8 años, 2 meses.

  • Autor
    Publicaciones
  • #18081

    cristord
    Participante

    <p>hola, tengo un problema que no entiendo…</p>
    <p>cuando escribo el codigo

    </p>
    <p>para llamar unos cuantos posts y poner titulo y demas y le agrego la funcion &lt;?php the_excerpt(); ?&gt; me sale el mismo extracto en todos los posts ejemplo, lo pongo asi…<br />
    </p>
    <p>entonces me salen todos los posts con el mismo extracto, pero si llamo los posts con esta otra funcion…<br />
    <br />
    no pasa ese problema, cual sera el fallo? es un bug? nota: no quiero usar al segunda funcion para llamar mis post, quiero usar la primera porque resulta que la segunda funcion no me deja usar campos personalizados.. otra nota: estoy usando estas funciones en un sidebar….
    </p>

  • #44117

    imported_study
    Participante

    Usalo así:

  • #44144

    cristord
    Participante

    gracias study, me sirvió, solo que el problema con the_excerpt fue resuelto, pero ahora el problema es el mismo pero con <?php the_permalink() ?> y <?php the_title(); ?> que raro esto, es algun bug o como soluciono esto?

  • #44169

    imported_study
    Participante

    Que raro, si los usas dentro del bucle (y luego de setup_postdata) no deberias tener problemas. Igual podes acceder a los mismos datos directamente desde el objeto post:

    por ej:


    pero siempre dentro del bucle.

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest