Problema grave con la codificación de caracteres

Inicio Foros WordPress Programación Problema grave con la codificación de caracteres

Este debate contiene 6 respuestas, tiene 3 mensajes y lo actualizó  davidlluna hace 8 años, 5 meses.

  • Autor
    Publicaciones
  • #17176

    josekso
    Participante

    <p>Hola, no sé si estoy en el sitio correcto.<br />
    Estoy buscando por internet la solución pero no doy con ella. Tenía un problema con el widget RSS el cual que se visualizaban mal los caracteres, entonces entré en el backend de wordpress y cambié la codificación de caracteres para ver si conseguía arreglarlo, con la mala fortuna de ponerlo en UTF-16. Ahora no solo se ve mal sino que no puedo modificar nada porque está todo en un texto plano en chino!! Algo así:<br />

    Quote:
    ⽴獣≳洠摥慩∽捳敲湥瀬潲敪瑣潩≮⼠ാ㰊楬歮爠汥∽瑳汹獥敨瑥•牨晥∽瑨灴⼺瀯畲扥⹡牣慥牥整挮浯眯⵰潣瑮湥⽴桴浥獥愯牲獡琭敨敭振獳戯畬灥楲瑮瀯楲瑮挮獳•祴数∽整瑸振獳•敭楤㵡瀢楲瑮•㸯਍ℼⴭ楛⁦䕉㘠㹝਍氼湩敲㵬猢祴敬桳敥≴栠敲㵦栢瑴㩰⼯牰敵慢挮敲敡瑲⹥潣⽭灷挭湯整瑮琯敨敭⽳牡慲⵳桴浥⽥獣⽳汢敵牰湩⽴敩挮獳•祴数∽整瑸振獳•敭楤㵡猢牣敥Ɱ牰橯捥楴湯•㸯਍ℼ敛摮晩ⵝ㸭਍उ਍氼湩敲㵬猢祴敬桳敥≴栠敲㵦栢瑴㩰⼯牰敵慢挮敲敡瑲⹥潣⽭灷挭湯整瑮琯敨敭⽳牡慲⵳桴浥⽥獣⽳瑳汹獥氯来捡⹹獣≳琠灹㵥琢硥⽴獣≳洠摥慩∽捳敲湥瀬潲敪瑣潩≮⼠ാऊउ਍氼湩敲㵬猢祴敬桳敥≴栠敲㵦栢瑴㩰⼯牰敵慢挮敲敡瑲⹥潣⽭灷挭湯整瑮琯敨敭⽳牡慲⵳桴浥⽥獣⽳獵牥挮獳•祴数∽整瑸振獳•敭楤㵡猢牣敥Ɱ牰橯捥楴湯•㸯਍㰊楬歮爠汥∽污

    </p>
    <p>No sé si me he cargado la base de datos, o tengo que cambiar manualmente en algún archivo de configuración o no sé dónde, pero no lo encuentro.</p>
    <p>Muchas gracias de antemano.
    </p>

  • #41185

    imported_j.conti
    Participante

    Hola

    Supongo que el problema es que no puedes leer, no hay problema de acceso,

    Ves a:

    http://www.buddypress-es.com/wp-admin/options-reading.php

    y en la última casilla pon UTF-8 y aprieta el único botón que encontrarás.

  • #41195

    josekso
    Participante

    No puedo, no aparecen casillas ni botones, solo una lista de texto plano en chino.

    http://live.creaerte.com/

    Este enlace se ve igual que en backend, solo caracteres ilegibles 😕

  • #41197

    imported_j.conti
    Participante

    Bueno, no desesperemos.

    Haz una cosa, a ver si así se soluciona.

    Entra en la base de datos, haz una búsqueda de UTF-16

    cuando lo encuentres, cambialo por UTF-8

    a ver si se arregla

  • #41213

    josekso
    Participante

    Esto es un quiero y no puedo (o sea, no sé). Creo que soy un negado con este problema… No sé acceder a la base de datos…

    ¿dónde debería estar?
    ¿es un archivo o archivos?
    ¿se accede a través de una URL?

    Me estoy desesperando, cuanto más me acerco al problema, más problemas encuentro.

  • #41217

    josekso
    Participante

    He conseguido arreglar el problema!!! jejeje.

    Ha sido de la manera más tonta. He forzado al navegador a que muestre el contenido en UTF-8, de esta manera y provisionalmente, puedo ver el backend bien y cambiarlo.

    Qué tontería más grande. Todo fue porque el widget que tengo a la derecha de un RSS se ven mal los caracteres (http://live.creaerte.com/). Seguramente termine por quitarlo y no comerme la cabeza más.

  • #41286

    davidlluna
    Participante

    Buenas, marca el hilo como resuelto para ayudar a otros usuarios a encontrar soluciones más fácilmente

    Saludos!

El foro ‘Programación’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest