Problemas con base de datos, desaparecen todas las entradas

Inicio Foros WordPress General WordPress.org Problemas con base de datos, desaparecen todas las entradas

Este debate contiene 2 respuestas, tiene 2 mensajes y lo actualizó  madsssup hace 7 años, 10 meses.

  • Autor
    Publicaciones
  • #18636

    madsssup
    Participante

    <p>Hola a todos. </p>
    <p>Antes de nada me presento. me llamo Fernando y soy el propietario del blog http://www.madsssup.com que trata sobre ocio en Madrid. No os moletéis en mirarlo ya que está caído y es por lo que he aterrizado aquí :-), pero os aseguro que está francamente bien.</p>
    <p>Antes de nada, agradecer a la gente que soporta esta web y a los que puedan aportar ayuda a mi consulta.</p>
    <p>El problema que tengo es que mi web funcionaba perfectamente alojada en un servidor (aruba). Haciendo pruebas dentro de CPanel eliminé la URL en Ajustes&gt;General&gt;Dirección de WordPress(URL). Y entonces ahí empezó mi pesadilla. La página dejó de funcionar y además ya no me dejaba entrar a http://www.madsssup.com/wp-admin/index.php. Subí por FTP al hosting de nuevo la copia de backup que tenía y daba igual. Me daba el mensaje de que las bases de datos estaban rotas, que añadiera una línea de código en wp-config para repararlas. Lo hacía y decía que las reparaba, pero seguía sin funcionar.</p>
    <p>Entonces, edité el fichero wp-config para ver los datos de la base de datos de mysql y la contraseña que me proporcionaba el proveedor y vi que eran distintos a los que tenía en mi back-up. Cambié los datos a los que me daba el proveedor y por lo menos ya me dejaba entrar en CPanel. Ahí podía ver el Theme y los widgets, pero no aparecve ninguna de las entradas que ya tenía y que está todo en el servidor donde está alojado. Ahora, cuando se entra en la web se ve parte del theme, con errores en los enlaces y ninguna entrada. Si vuelvo a poner los parámetros de mysql que tenía en mi back-up, vuelvo a quedarme sin acceos a CPanel y me vuelve a decir que las bases de datos están estropeadas.</p>
    <p>En fin, no sé si falta algún dato y si alguien me puede ayudar. Lo agradeceré enormemente.</p>
    <p>Un saludo,<br />
    Fernando
    </p>

  • #45263

    tu problema no se va resolver subiendo archivos,
    vete a la base de datos y en la tabla wp_options,
    1.- busca “siteurl” y pega “http://www.madsssup.com/wp-admin/index.php”
    2.- busca “home” haz lo mismo.

    y trata de dejar el wp-config como estaba.

  • #45279

    madsssup
    Participante

    Hola dragondeluz,

    ante todo muchas gracias por tu respuesta.

    No encuentro el fichero wp_options ¿podría ser “wp_settings”?

    Si entro en wp_settings y busco siteurl, no sé muy bien donde ponerlo. Copio donde aparece para saberlo exactamente:

    No sé si esto puede valer para saber exactamenmte dónde ponerlo.

    Gracias de nuevo y un saludo:
    Fernando

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest