Problemas con el Footer.php

Inicio Foros WordPress Themes y Diseño Problemas con el Footer.php

Etiquetado: ,

Este debate contiene 9 respuestas, tiene 4 mensajes y lo actualizó  imported_dragondeluz hace 9 años.

  • Autor
    Publicaciones
  • #14818

    dea4ever
    Participante

    <p>Buenas… este es mi primir post en esta gran comunidad. Espero que me puedan ayudar con el problema que estoy teniendo.<br />
    El problema es el sigueinte:<br />
    Desde hace unos dias estoy teniendo problemas con el footer de mi wordpress, aparece debajo del sidebar. y no al final de la pagina ocupando el tamaño total de la página. No se si me explico, pueden ver el problema en vivo y en directo en esta direccion http://tapaycontratapa.com</p&gt;
    <p>La version de wordpress es WordPress 2.8.5<br />
    Los plugins son:<br />
    Akismet<br />
    Another WordPress Classifieds Plugin<br />
    Easy AdSense<br />
    Favicon Manager<br />
    Google Analytics for WordPress<br />
    Google XML Sitemaps<br />
    Highlight Author Comments<br />
    MCEComments<br />
    Poppy´s videos<br />
    rpx<br />
    Simple Tags<br />
    SocioFluid<br />
    Subscribe To Comments<br />
    Top Commentators Widget<br />
    VR-Visitas<br />
    WordPress.com Stats<br />
    WP-ContactForm<br />
    El theme es uno creado por mi pero antes no tenia ese problema.</p>
    <p>Si necesitan mas datos con gusto se los dare.<br />
    Saludos y gracias.
    </p>

  • #33657

    davidlluna
    Participante

    Hola, te falta o te sobra una etiqueta DIV en algún sitio o bien hay algun código HTML mal formado, el Validador the puede ayudar

    http://validator.w3.org/check?uri=http%3A%2F%2Ftapaycontratapa.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    Hay algunos errores del tipo

    [b]Opening and ending tag mismatch: body line 147 and div[/b]

    Saludos!

  • #33658

    dea4ever
    Participante

    Muchas gracias. Voy a probar… aunque no tengo mucha idea de programación…

    Si te paso el theme tendrias la amabilidad de revisarlo?
    Si no podes no hay problema. Gracias de todas maneras.

  • #33686

    dea4ever
    Participante

    Todavía sigo con el problema… la verdad no se mucho de programación web. Si alguien me puede ayudar estaré mas que agradecido. :mrgreen:

  • #33688

    davidlluna
    Participante

    Buenas

    Cuando dices “antes no tenia ese problema.” es porque cambiaste algo en la plantilla. O bien instalaste algun plugin nuevo, prueba a desactivar todos los plugins para descartarlos.

    Tambien puedes “copiar el codigo fuente” generado pasarlo a un archivo estatico html, eliminar el contenido y los links y pasar el html por el validador para que te de una idea de donde tienes el problema

    Saludos

  • #33692

    dea4ever
    Participante

    Hola nuevamente… te cuento lo que hice…
    Desactive todos los plugins y quite todos los gadget del sidebar.
    Pero sigue con lo mismo.
    También he borrado y cargado la plantilla de nuevo. Sigue que con lo mismo.

    He probado la plantilla en una instalación limpia de wordpress en appserv en mi pc. Pero ahí anda sin problemas.
    Estoy bastante confundido.

    Gracias por la ayuda y el tiempo.
    Alguna otra sugerencia?…

    Me parece que voy a tener que instalar wordpress todo de nuevo. 🙄

  • #33693

    imported_Mno4K
    Participante

    Busca en tu index.php o footer.php lo siguiente:

    arriba agregale un </div>:

  • #33718

    dea4ever
    Participante

    Busca en tu index.php o footer.php lo siguiente:


    arriba agregale un </div>:

    Muchas gracias por la ayuda… al final opte por instalar todo de nuevo… un dolor de cabeza porque no me tomo el backup de la BD.
    De todas maneras el problema me surgió de nuevo. Y lo pude resolver… (porque no me di cuenta antes!). El problema estaba en un código JS en un widget del sidebar. Lo corregí y salio andando de nuevo.
    Gracias nuevamente por la ayuda y por el tiempo dedicado.

    Aprendizaje: Si te pasa esto… primero saca todos los widget y después mira bien! Sino vas a renegar como yo.
    Pueden visitar mi blog si tienen ganas. http://tapaycontratapa.com

  • #33719

    imported_Mno4K
    Participante

    Joya, que bueno que lo pudiste solucionar. Y sí, cuando hay algún problema, los primeros sospechosos son los plugins, widgets, y demás agregados.

    Saludos!

  • #33801

    Yo tuve un problema similar cuando empece con wordpress, y el problema era que habia copiado y pegado de WORD los contenidos. La plantilla simplemente se mostraba por la mitad nunca aparecía el footer, lo que hice fue copiar todo el html del navegador pegarlo en dreamweaver y examilarlo… desde entonces copio primero al block de notas y luego al blog.

El foro ‘Themes y Diseño’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest