PROBLEMAS CON PERMALINKS

Inicio Foros WordPress SEO – SEM PROBLEMAS CON PERMALINKS

Este debate contiene 9 respuestas, tiene 5 mensajes y lo actualizó  locuela hace 9 años, 1 mes.

  • Autor
    Publicaciones
  • #14552

    locuela
    Participante

    <p>Hola.<br />
    Tengo un conflicto con los permalinks.<br />
    Estoy aún desarrollando un blog que no tengo dado de alta en ningún buscador.<br />
    En la opción Permalinks siempre he tenido puesta la predeterminada y me ha funcionado todo bien. Ahora he querido cambiarla añadiendo en el campo de "Personalizada": /%category%/%postname%/ para que me ponga en el directorio los nombres de las categorías y de los post.<br />
    Pero sólo me reconoce en la página index todas las imágenes que he metido en el header.php y en el sidebar.php con html, y necesito que me reconozca estas imágenes en todas las páginas.<br />
    Las imágenes las tengo guardadas dentro del directorio de wordpress.<br />
    ¿Cómo se puede hacer?</p>
    <p>Gracoas
    </p>

  • #32855

    thinway
    Participante

    ¿Has actualizado tu .htaccess? Cuando se cambia el formato de los permalinks debe hacerse esto para que los cambios tengan efecto.

    Saludos.

  • #32858

    gventura
    Participante

    Si no tienes el fichero htaccess en el servidor deberías hacer:

    1. Acceder al ftp con un cliente tipo file zilla.
    2. Ir a la raíz del directorio dónde se encuentra los ficheros de wordpress.
    3. Crear un fichero nuevo con este nombre .htaccess y darle permisos de escritura o CHMOD 777.
    4. Acceder de nuevo en las opciones de wordpress y ver si no da ningún error dónde diga error en permisos o no se ha podido escribir el fichero. Si fuera así él te muestra el código que debería contener, así que podrías editarlo manualmente.

    Pero por lo que dices parece que te falla la ruta al fichero de algunas imágenes, que deduzco, las has introducido manualmente en tu theme.

    Puede ser que el error venga porqué la ruta está mal puesta tipo ../imagenes/logo.png

    Si está puesto así el problema es que para él representa que se encuentra en una carpeta inexistente, ya que usas el formato /%category%/%postname%/ dónde category y postname representan carpetas.

    Si el error es este puedes usar ruta absolutas, en vez de relativas.

    Si añades las imágenes con una barra al principio lo dices que partes desde la raíz del servidor, pero recomiendo usar:
    < ? php bloginfo( ‘ template_directory ‘ ); ? >/imagenes/logo.png
    ya que dices que el fichero siempre se encuentra dentro del directorio de tu theme en una carpeta llamada imágenes.

    Espero que sea alguno de estos dos errores.

    Saludos.

  • #32873

    locuela
    Participante

    Creo que es la ruta, Gventura.
    Muchas gracias, voy a probarlo con el código php a ver si me sale y os cuento.
    Por cierto, ¿se pone así “tu-código-php imagen.jpg” (todo junto entre comillas) con el src= delante?
    Es que cuando escribo el código no me sale en el mensaje.
    Saludos. Sois un encanto.

  • #32907

    imported_Fernando
    Participante

    Usa el botón de código o las comillas inversas, las que están a la derecha de la Ñ en el teclado, pero mejor con el botón de CODIGO, te mostrará algo así:

  • #32910

    Jonathan
    Participante

    Buena la pregunta yo queria hacerla 😛

    ¿Has actualizado tu .htaccess? Cuando se cambia el formato de los permalinks debe hacerse esto para que los cambios tengan efecto.
    Saludos.

    donde se actualiza .htaccess??? y como hay q actualizar 😛

  • #32911

    imported_Fernando
    Participante

    Si la carpeta donde está instalado WP tiene permisos de escritura se actualiza (o se crea) solito – bueno, lo hace WP – en caso contrario tienes que modificarlo o crearlo manualmente (con un editor de texto plano, por ejemplo) y subirlo tu mismo. O eso, o cambiar los permisos de la carpeta donde se instala WP.

    Ejemplo:

    Normalmente te dan acceso por ftp a tu sitio y tu ves una carpeta en blanco o unos index.html de página en construcción. Ahí es donde instalas WordPress. Ahora bien, en realidad esa no es la carpeta raiz del servidor, y para que se cree ahí un fichero oculto (.htaccess) la carpeta (tu no la ves normalmente) debe tener permisos de escritura.

    En algunos servidores tu estarías en una ruta del estilo “/var/users/vhosts/tudominio.com/httpdocs/” y dentro de httpdocs es donde pondrías WP (y sería lo único que verías, dentro de esa carpeta, opaca para ti). si tienes acceso a “subir” un nivel de carpetas puedes cambiar tu mismo los permisos a la carpeta httpdocs, en caso contrario te toca pedirlo o hacer el apaño

  • #32914

    Jonathan
    Participante

    y en esa carpeta httpdocs q dices ahi se encuentra la carpeta .htaccess???
    y si no esta tengo q crearla???

  • #32940

    thinway
    Participante

    [quote]y en esa carpeta httpdocs q dices ahi se encuentra la carpeta .htaccess???[/quote]

    .htaccess es un archivo, no una carpeta, y como te han explicado debe estar dentro de la carpeta httpdocs (o como se llame la carpeta).

    Si no tienes el archivo tendrás que crearlo con un editor de texto plano. Como te han explicado, si tienes los permisos adecuados en esa carpeta se creará automáticamente, en caso contrario deberás hacerlo tú y subirlo al servidor.

    Saludos

  • #32962

    locuela
    Participante

    Ya está. Por fin me las ha reconocido. Tras varios intentos, GVENTURA, he cambiado la ruta de las imágenes y las películas, que había metido manualmente en los .php de mi theme, con el código mágico php que me has facilitado , y ¡¡ME HA FUNCIONADO!! Pero sólo me funciona en el Firefox, si lo visualizo en Internet Explorer 8 no me visualiza el vídeo .swf (que he cambiado la ruta también con el mismo código). ¿Será porque el Intermet Explorer no me va bien?

    Gracias y saludos.

El foro ‘SEO – SEM’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest