Problemas en la base de datos

Inicio Foros WordPress General WordPress.org Problemas en la base de datos

Este debate contiene 5 respuestas, tiene 2 mensajes y lo actualizó  LGrusin hace 7 años, 4 meses.

  • Autor
    Publicaciones
  • #21121

    getenner
    Participante

    <p>Manejo un blog http://www.lenguajeclaro.com/blog, con tema arthemia levemente personalizado. </p>
    <p>En principio, parecía funcionar bien. Por cuestiones personales y laborales, no pude dedicarme al blog durante varios meses. Cuando finalmente dispongo del tiempo para ello, me encuentro con que varios plugins, en particular los que tienen que crear tablas para su funcionamiento, no funcionan. Tal es el caso de las agendas, los buscadores de links rotos, etc.</p>
    <p>En el ínterin también actualicé la versión de WordPress (a 3.1), lo que siempre es traumático: después de mucho rogar y pelear logré que los responsables del servidor tocaran algo en algún lugar para volver el blog a la vida.</p>
    <p>Actualmente, las cuestiones básicas funcionan, pero todo el potencial del blog está desperdiciado por el problema que mencioné sobre la escritura de tablas nuevas, y esto me resulta imperdonable e insoportable.</p>
    <p>Me permito reproducir aquí algunos mensajes que fui obteniendo en mi largo e inútil recorrido por las páginas del blog y de administración de la base de datos (siempre sin tocar nada; sólo mirando tristemente para tratar de entender dónde está el problema).</p>
    <p>• En el escritorio del blog, la instalación del plugin Events devuelve el siguiente mensaje (hasta antes de realizar los cambios del año pasado funcionaba, y de hecho existe la tabla original en la base de datos):</p>
    <p>

    Quote:
    There was an error locating the main database table for Events. Please deactivate and re-activate Events from the plugin page!!<br />
    If this does not solve the issue please seek support at http://meandmymac.net/support/.

    </p>
    <p> La desactivación y reactivación es inútil.</p>
    <p>• Al acceder a la base de datos en el servidor me encuentro con los siguientes mensajes:</p>
    <p>Database uv0001_blog running on localhost<br />
    Error<br />
    The additional Features for working with linked Tables have been deactivated. To find out why click here.</p>
    <p>[el here es lo siguiente]<br />
    Database uv0001_blog running on localhost<br />
    PMA Database … not OK[ Documentation ]<br />
    General relation features Disabled</p>
    <p>[la documentation es la siguiente]</p>
    <p>See the Quick Install section in this document for a quick way of creating those tables. Also, if you are using a Windows server, read FAQ 1.23. </p>
    <p>If you are the only user of this phpMyAdmin installation, you can use your current database to store those special tables; in this case, just put your current database name in$cfg[$i]. </p>
    <p>If you are setting up a multi-user phpMyAdmin installation, you will need to create a new database and setup special privileges, so, as superuser:<br />
    [Y sigue…]</p>
    <p>En fin, ¿esto les dice algo? ¿Podrán orientarme?<br />
    Desde ya, muchísimas gracias
    </p>

  • #51924

    LGrusin
    Miembro

    Uf, los autores de muchos plugin con el tiempo dejan de dar soporte y no continuan el desarrollo.

    Es imprescindible que tanto las versiones de plugins, themes y WordPress estén actualizadas y sean compatibles entre ellas.

    1 – Actualiza WordPress a su última versión, (actualmente la 3.1.2)
    2 – Si algún plugin no está actualizado, actualizalo. Si es obsoleto eliminalo y busca otro similar. No mezcles versiones que pueden dar conflictos entre ellas.
    3 – Comprueba que todo va bien y en caso contrario dasactiva plugins y vuelve a comprobar hasta detectar el causante del problema.

    Es imprescindible que el servidor funcione adecuadamente con WordPress para evitar quebraderos de cabeza. La mayoría van bien pero por lo que he podido leer en el Foro hay mucho incompetente por ahí.

    Un saludo

  • #51942

    getenner
    Participante

    LGrusin, muchas gracias por tu atenta y detallada respuesta. En vista de tu tan amable disposición, me permito repreguntar. Antes debo decirte que cada vez que he actualizado la versión de WordPress, el blog dejó de funcionar y me costó sudor y lágrimas lograr que el proveedor se ocupe de ello (el problema es “mío”); por ello, por ahora me abstengo de actualizar nuevamente.
    En cuanto al problema en cuestión, no afecta sólo al plugin events, sino a todos los que tienen que generar una tabla. Me pregunto si no está diciendo algo más estructural el mensaje

    [quote]PMA Database … not OK[ Documentation ]
    General relation features Disabled[/quote]

    Gracias nuevamente, y si consideras que debo buscar algún tipo particular de asistencia, escucho con toda atención.
    Saludos cordiales
    Gabriela

  • #51948

    LGrusin
    Miembro

    Esos mensajes de servidor ni siquiera el usuario debería verlos y mucho menos tiene la posibilidad de ponerle solución. Suelen ocurrir cuando se trabaja en el servidor o se actualiza MySQL o PHP y se deja el trabajo a medio. Igual ni se han enterado (lo cual es preocupante). ¿Has consultado con ellos?

    También puede ocurrir que alguna característica, en este caso PMA, no está configurada en tu servidor. Si no te afecta al funcionamiento normal, ni caso.

    Comprendo que te metan el miedo en el cuerpo pero el problema es de ellos. Un servidor para soportar WordPress necesita las versiones de MySql y PHP adecuadas y bien configuradas. Esto no es algo especial, el 95% de los servidores existentes están perfectamente preparados para WordPress y cumplen con los requisitos.

    No sé exactamente las razones por las que existe una proliferación de personal poco competente y poco cualificado, quizás el bajo precio de ciertos servidores influye en ello. Igual te dicen que, con ese plan de alojamiento, no te incluyen esas opciones.

    OJO, otra cosa es que estos errores se generen por mala ejecución en los códigos. Con lo que el servidor muestra estos mensajes de alerta. En este caso el problema si es tuyo. Por eso dije que desactivaras plugins y códigos extraños y fueras probando.

    Es imprescindible que WordPress, themes y plugins estén actualizados a su última versión. Al contrario que lo que piensan muchos, los errores aparecen con el tiempo por quedarse obsoletas las versiones y no haber actualizado a tiempo. De hecho cuando el servidor actualiza MySQL y PHP suelen aparecer los problemas. Este podría ser uno de esos casos.

    Perdón por el rollo.

    Un saludo

  • #51954

    getenner
    Participante

    LGrusin, ha sido una buenísima experiencia participar en el foro, gracias a ti. Después de HORAS de conversación telefónica y por chat con los proveedores, he logrado que se fijen si no había más de una versión instalada de wordpress dando vueltas (muchas manos en un plato…). ¡Y así era! Hicieron un mínimo orden y ¡voila!

    Pero, repito, gracias a tu disposición, seguiré consultando en el foro mis dudas, para convertir en una usuaria informada y competente.

    ¡Hasta pronto!
    Saludos cordiales
    Gabriela

  • #51974

    LGrusin
    Miembro

    De nada, para eso estamos.

    Por favor, cierra el Hilo para que otros usuarios puedan saber que la duda ha quedado resuelta.

    Un saludo

El foro ‘General WordPress.org’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest