Que necesito??

Inicio Foros WordPress Plugins Que necesito??

Este debate contiene 9 respuestas, tiene 3 mensajes y lo actualizó  imported_study hace 8 años, 7 meses.

  • Autor
    Publicaciones
  • #15810

    capalma
    Participante

    <p>Hola. Me gustaría saber que plugin necesito para poder crear una especie de pop-up, recordando que para ver una sección de mi weblog wordpress, es necesario registrarse o logearse en el mismo.<br />
    Gracias<br />
    SAlu2
    </p>

  • #36500

    marcialsoto
    Participante

    Hola, el Wibiya hace algo similar http://wibiya.com/ Mucha suerte.

  • #36510

    imported_study
    Participante

    seria un poco tosco pero podes usar un alert de javascript combinado con una funcion php y así no tenes que usar ningun plugin:

    Por supuesto podes hacer algo un poco mas desarrollado utilizando un div y css desde javascript.

  • #36852

    capalma
    Participante

    Como y donde introduzco eso? Es posible que solo les aparezca a los visitantes?
    Gracias
    SAlu2

  • #36853

    imported_study
    Participante

    De hecho eso ya esta preparado para mostrarse solo a los usuarios que no esten logueados. Lo que si seria conveniente colocar una cookie en el navegador del usuario pàra que el aviso solo se muestre una vez (sino es muy molesto), el código deberia ser así (toma en cuenta que no lo probe):

    primero insertamos una cookie, esto va arriba de todo de tu header (bien arriba de todo sino no funciona, no dejes espacios en blanco antes):

    Y esto es lo que da el mensaje en si, ponelo donde quieras (te recomiendo el archivo footer.php). Por supuesto podes poner el mensaje que quieras.

    [b][u]Por favor, si alguno de los que sabe php me puede corregir el código, porque no estoy acostumbrado a trabajar con cookies.[/u][/b]

  • #36854

    imported_study
    Participante

    Ojo tene cuidado que donde dice amp; amp; en realidad van dos &&

  • #36915

    capalma
    Participante

    No me va. No me deja añadir la cookie. La inserto arriba del todo, guardo y al previsualizar, se me pone el texto en php arriba de todo…

  • #37050

    imported_study
    Participante

    Fijate si estas abriendo y cerrando correctamente las etiquetas de <?php y ?>

  • #37074

    capalma
    Participante

    he hecho copy y paste del codigo que me pusiste… :S
    Gracias
    SAlu2

  • #37086

    imported_study
    Participante

    mejor escribilo a mano, este foro tiende a deformar el código, fijate que deja un espacio entre < y ? debe ser por eso.

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest