TimThumb en Multisite – No encuentra imágenes aunque la URL es válida

Inicio Foros Otros WordPress y similares Multisitio – BuddyPress TimThumb en Multisite – No encuentra imágenes aunque la URL es válida

Este debate contiene 4 respuestas, tiene 3 mensajes y lo actualizó  arsocado hace 7 años, 6 meses.

  • Autor
    Publicaciones
  • #21438

    arsocado
    Participante

    <p>Muy buenas,<br />
    estoy desarrollando un tema nuevo y llevo un par de días en un camino sin salida usando Timthumb para un carrusel de posts recientes.<br />
    la cuestión es que las imágenes no aparecen aunque si exploro la URL que genera timthumb sí me sale la imagen, eso sí, en una pestaña aparte.<br />
    la dirección del blog es la siguiente: <a href="blog.letraturbia.es">blog.letraturbia.es</a><br />
    es multisitio y uso el plugin "ThreeWP Broadcast" para lanzar las entradas desde los sitios a la portada. Durante un momento funcionó sin problemas, pero tuve que ressubir los archivos de wp recodificados en ANSI porque me daba el error ‘headers already sent…’.<br />
    le he dado varias vueltas al asunto, pero no doy con la tecla.<br />
    el código del carrusel para tomar las imágenes es el siguiente:<br />
    <pre><code>&lt;br /&gt;
    &lt;?php&lt;br /&gt;
    if (has_post_thumbnail()):&lt;br /&gt;
    $thumbnail = wp_get_attachment_image_src(get_post_thumbnail_id(),&#39;full&#39;);&lt;br /&gt;
    echo &#39;&lt;img src=&quot;&#39;.get_bloginfo(&#39;template_url&#39;).&#39;/timthumb.php?src=&#39;.$thumbnail[0].&#39;&amp;w=650&amp;h=235&amp;zc=1&amp;q=95&quot; alt=&quot;&#39;.get_the_title().&#39;&quot; /&gt;&#39;;&lt;br /&gt;
    endif;?&gt;&lt;br /&gt;</code></pre>
    <p> en functions.php simplemente activo la posiblidad de thumbnails.<br />
    por otra parte, y creo que tiene algo que ver, en la barra de administración de wp cuando estoy conectado, no aparecen las imágenes típicas de los submenús (p.e.:cuando me pongo encima de Mis sitios &gt; (I) sitio, donde (I) es la imagen, ésta sale como el típico cuadrado de imagen no encontrada.</p>
    <p> por favor, si alguien sabe como resolver esto se lo agradecería.</p>
    <p> Muchas gracias de antemano.
    </p>

  • #52822

    imported_fliberty
    Participante

    La verdad es que yo desistí anteriormente de thimthumb, el script en sí es muy bueno, pero a veces su integración se hace complicada, es por tal motivo que actualmente vengo utilizando el script resizer en mis sitios web, y a diferencia del script thimthumb, me da la posibilidad de utilizar cualquier tipo de imagen, este ubicada esta en host, subida con el mediauploader de wordpress o “alojada en un sitio externo” dicho sea de paso esto último ayuda cuando se quiere evitar el consumo de espacio en disco y del ancho de banda.

  • #52828

    23r9i0
    Participante

    normalmente es por culpa de la carpeta cache que no tiene permisos 777.
    Pero yo no he probado el que comenta fliberty pero tiene buena pinta, yo probaria el que comenta fliberty.

  • #52830

    imported_fliberty
    Participante

    Un problema que tuve con el script thimthumb, era que debía especificar las URL desde donde podía cargar imágenes, pero por más que declaraba las URL de estos servidores, la verdad era que no me cargaba las imágenes externas.

    En todo caso como dice S3R9i0, verifica los permisos de la carpeta de caché, ya que ese puede ser el problema, ya que si como dices a ver la URL de la “imagen no encontrada” esta es correcta, entonces sin lugar a dudas es el permiso de la carpeta cache.

  • #52848

    arsocado
    Participante

    Muchas gracias por vuestro interés!!
    gugleando enfermizamente he encontrado a un tipo que ha modificado el timthumb para que rastree los directorios blog.dir y funciona!!!!!

    os dejo el enlace por si os viene bien ahora o en el futuro. la única pega es que no está basado en la última versión (la 1.26), pero bueno, va de lujo.

    http://compu.terlicio.us/2011/04/timthumb-for-wordpress-multisite/

    de nuevo, muchas gracias por vuestro interés.

El foro ‘Multisitio – BuddyPress’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido