TinyMCE no me deja copiar de Word

Inicio Foros WordPress Plugins TinyMCE no me deja copiar de Word

Este debate contiene 6 respuestas, tiene 2 mensajes y lo actualizó  imported_fermars hace 7 años, 2 meses.

  • Autor
    Publicaciones
  • #20900

    imported_fermars
    Participante

    <p>Hola a todos, sabéis que este plug-in tiene la opción de pegar de Word para insertar texto desde ese programa (u otros similares) quitando códigos "raros" y dejando el texto con opciones básicas como subradados, negritas, saltos de línea y cosas así. A mi me es muy útil porque habitualmente lo tengo que usar pero desde hace algún tiempo no me funciona, es como si lo pegara directamente. Si uso la opción de "pegar como texto plano" ese si funciona, pero claro, me quita todos los formatos. ¿A alguien le ha pasado?</p>
    <p>Saludos.
    </p>

  • #51252

    LGrusin
    Miembro

    Si te refieres a que te falla el botón de importar texto desde Word en el editor Visual. Actualiza a 3.1.1 posiblemente sea alguno de los defectos similares a; mal funcionamiento del editor TinyMCE, falta del botón visual, etc…

    Yo es que escribo los posts con Notepad o Bloc de notas. Pues no hace años ni nada que no uso Word… miento uso OpenOffice… 😉

    Un saludo

  • #51254

    imported_fermars
    Participante

    No, el botón si está pero vamos que cuando le pulsas, se abre la ventana para pegar de Word (por cierto, yo también uso OpenOffice y pasa igual), pegas el texto CON formato le das a aceptar y no te hace ni caso, es como si hubieras pegado directamente en el formulario de edición normal de WordPress. Está todo actualizado y sigue de la misma manera… en fin, seguiré investigando.

    Gracias LGrusin.
    Saludos.

  • #51258

    LGrusin
    Miembro

    Acabo de probar y me va. He usado la versión 3.1 en inglés.

    Prueba sólo por curiosidad poner en el wp-config.php la siguiente línea:

    define(‘CONCATENATE_SCRIPTS’, false );

    Esto se supone que era un problema con la versión 3.1 y que se había corregido.

    Por cierto, y si lo instalas en inglés.

    Bueno me voy….

    Un saludo

  • #51259

    imported_fermars
    Participante

    Lo del define(‘CONCATENATE_SCRIPTS’, false ); no funciona.

    Tendré que investigar un poco más….

  • #51265

    LGrusin
    Miembro

    Y digo yo, ¿Sólo es ese el único problema que notas?

    Lo del concatenate scripts es porque en algunos servidores dejó de funcionar la compresión de archivos javascript después de la actualización a la versión 3.1. Con lo cual ha afectado a códigos que usan algunos themes, plugins y al propio DashBoard de WordPress. Sobre todo el editor TinyMCE, los botones de Visual y HTML, el scroll de los menús y algunas cosas más que usan javascripts.

    Por eso dije que probaras a ver si sonaba la flauta.

    De todas forma te digo lo mismo en estos casos. Desactiva plugins y prueba.

    Espero que te sirva de ayuda. Yo es que odio que una máquina me tome el pelo. A todo le tengo que buscar explicación… 😉

    Saludos

  • #51266

    imported_fermars
    Participante

    A mi me pasa un poco lo mismo, lo dicho voy a investigar un poco más en vista de que parece un error muy poco común. Y si, es lo único que he notado, que si no lo usara como tu, no me habría dado ni cuenta.. Podría ser un “bug” pero si nadie lo usa, poco remedio van a poner…

    Bueno, ya diré algo.
    Gracias!

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest