UMapper – Error al actualizar de WP 2.6.5 a 2.7

Inicio Foros WordPress Plugins UMapper – Error al actualizar de WP 2.6.5 a 2.7

Etiquetado: 

Este debate contiene 5 respuestas, tiene 3 mensajes y lo actualizó  merlyn333 hace 9 años, 11 meses.

  • Autor
    Publicaciones
  • #11549

    merlyn333
    Participante

    <p>Reciban un caluroso saludo desde las planicies mágicas de Amor y Sexualidad.</p>
    <p>Recientemente actualicé nuestro blog de la versión 2.6.5 a la 2.7, y el plugin UMapper presenta el siguiente error:</p>
    <p>

    Quote:
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/amorysex/public_html/wp-content/plugins/umapper/Umapper.php on line 37

    <br />
    -<br />
    Ésto es lo que se muestra en la línea 37:</p>
    <p>

    Code:
    &lt;?php<br />
    /**<br />
    * Main plugin functionality<br />
    *<br />
    * @category WordPress<br />
    * @package Umapper<br />
    * @subpackage Plugins<br />
    * @copyright 2008 Advanced Flash Components<br />
    * @version 1.0.0<br />
    */</p>
    <p>/**<br />
    * Zend_XmlRpc_Client<br />
    */<br />
    require_once ‘Zend/XmlRpc/Client.php’;</p>
    <p>/**<br />
    * Pluggable functions<br />
    */<br />
    require_once dirname(__FILE__) . ‘/../../../wp-includes/pluggable.php’;</p>
    <p>/**<br />
    * @category WordPress<br />
    * @package Umapper<br />
    * @subpackage Plugins<br />
    * @copyright 2008 Advanced Flash Components<br />
    * @version Release: 1.0.0<br />
    * @author Victor Farazdagi &lt;[email protected]&gt;<br />
    */<br />
    class WordPress_Umapper<br />
    {<br />
    /**<br />
    * Uri where plugin is located<br />
    *<br />
    * @var string<br />
    */<br />
    [b]protected $pluginUri;[/b]</p>
    <p> /**<br />
    * Current API Key<br />
    *<br />
    * @var string<br />
    */<br />
    public $pluginIApiKey;

    </p>
    <p>-<br />
    ¿Cómo puedo resolver éste error?</p>
    <p>Les agradezco de antemano y que tengan un feliz año nuevo.
    </p>

  • #24093

    imported_Mno4K
    Participante

    Me suena a que el plugin no es compatible con la versión 2.7, fijate si el autor no ha sacado una versión actualizada.

  • #24111

    imported_Fernando
    Participante

    La misma [url=http://wordpress.org/extend/plugins/umapper/faq/]página del plugin te lo indica[/url], es debido a la versión de PHP. Quizás en tu servidor han cambiado la versión o igual WP 2.6 era menos exigente en ese sentido.

    Cita original del creador del plugin en la FAQ:

    [quote]I am getting “parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in Umapper.php..” error. What causes it?

    You are using PHP4 and PHP5 is required to run the plugin[/quote]

  • #24138

    merlyn333
    Participante

    Probablemente si sea la versión de PHP, pues tuvimos que cambiar de hosting y actualmente está en la versión [b]4.4.7[/b]. y anteriormente estábamos en la versión [b]5.2.6[/b].

    Es preocupante éste aspecto, ya que los mapas hacen parte importante de nuestros servicios. Vamos a ver qué podemos hacer al respecto.

    Muchas gracias Mno4K y Fernando.

  • #24143

    imported_Fernando
    Participante

    Merlyn, dile a tu proveedor de hosting el problema y que te cambie el sitio a un servidor que tenga PHP 5.x, para ellos es fácil y no deberían ponerte problemas en hacerlo.

    Es mas, un hosting que aún esté en PHP 4.x es para huir de el lo antes posible, no por esto sino por [url=http://carrero.es/el-fin-de-php4-es-hora-de-cambiar-a-php5/764]otros problemas asociados[/url]

  • #24150

    merlyn333
    Participante

    Si, lo haré. Gracias Fernando.

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido