WordPress y BBpress

Etiquetado: , ,

Este debate contiene 17 respuestas, tiene 7 mensajes y lo actualizó  simplepanas hace 9 años, 2 meses.

  • Autor
    Publicaciones
  • #11731
  • #24940

    imported_Fernando
    Participante

    Si pueden ser los mismos, para ello hay que tener activa la integración de WP y bbpress (que yo no activé, sorry). Si está activa puedes hacer login en el foro con el mismo usuario del blog 🙂

    Te muevo el mensaje de sitio ¿ok?

  • #25657

    imported_emip3
    Participante

    Consulta, luego de activar la integración entre ambos me desaparecieron los usuarios registrados en BBP, no aparecen en WP ni en BBP… simplemente desaparecieron…por otro lado, tampoco puedo acceder a la administracion del BBP con el usuario de WP… y ahora?…gracias de antemano…

  • #25719

    markitocjs
    Participante

    ¿Cómo activaste la integración?

    te digo los pasos por las dudas que me olvide de pasar más tarde:

    • 1. Marca la casilla de integrar wordpress con bbpress.
    • 2. Marca la casilla de integrar cookies.
    • 3. Rellena todas las claves las de wp-config.php y las de la página
      http://tublog.com/wp-admin/options.php
    • 4. Marca la otra casilla que dice algo de compartir base de datos.
    • 5. completa los datos.

    Pd: en la integración de cookies pone la dirección donde tienes instalado wordpress y la dirección de la pagina del blog.
    PD2: si no entendiste algo postea.

  • #25724

    imported_emip3
    Participante

    lo hice tal cual los 5 pasos que describís… ahora, lo que hice fue:
    1 Crear una nueva base de datos MySQL
    2 Exporté las tablas bb_ de la base compartida con WP a esa nueva base de datos
    3 Hice un Upgrade a BBP 1 Alpha 6
    4 Sigo sin poder entrar como administrador (ni con ningun usuario), aún cuando en la table bb_user están todavía los usuarios y el administrador
    5 Prefiero que estén separados porque en definitiva no necesito compartir la BD
    6 ¿cómo podré hacer para ingresar como Administrador? (cuando le pido que me envíe la contraseña por mail me dice que el usuario no se encuentra registrado…)
    7 MIL GRACIAS!

  • #25728

    markitocjs
    Participante

    nunca me paso eso… hmm si no tenes muchos posts ni temas ni foros en el foro prueba a desinstalarlo del todo y volverlo a instalar

  • #25732

    imported_emip3
    Participante

    me lo temía… gracias markitocjs!, vamos a ver cómo me las arreglo, de todas maneras, dejo el tema abierto por si a alguien se le ocurre la solución más práctica para alguien con un foro muy lleno de cosas… 😀

  • #25737

    markitocjs
    Participante

    creo que exportando la tabla donde están los posts y volviendola a subir al nuevo foro no habría problemas…

  • #25782

    FloiT
    Participante

    pues sí, gracias por dejar este tema abierto.

    Yo quiero instalar un foro bbpress integrado con un WordPress desde cero y no hay manera.
    Echo de menos un readme.htm tipo "la famosa instalación en 5 minutos". He probado lo que dicen en [url=http://bbpress.org/documentation/installation/]la web oficial[/url] (subir los archivos, poner el languages si quieres e ir a la url), pero no funciona porque me redirige al archivo "…./install.php?step=1", y el install.php no existe, almenos en la versión 1.0-Alpha-6, que es la que está en la web oficial ahora mismo.

    Primero añadí la carpeta "languages" y el archivo .mo. Por lo que he entendido, bbpress se instala en una carpeta independiente de las carpetas wordpress. He visto que tiene un wp-config-sample.php, pero aparte del es_ES, ¿qué datos tengo ke ponerle para que funcione integrado con WordPress? ¿Los mismos que el wp-config.php de WordPress?

    Gracias

  • #25815

    FloiT
    Participante

    Perdón, acabo de ver [url=http://ayudawp.com/bbpress-10-alpha-7-y-los-plugins/]el post del blog relacionado con el bbpress Alpha[/url], retiro mi consulta anterior y me esperaré a que salga la versión estable…

  • #25979

    imported_alv4
    Participante

    [b]Gracias…[/b]
    perdon la tardanza..
    pero ya 🙂

  • #31920

    Furia_negra
    Participante

    Hola he intentado por todos los medios integrar el foro con word press y no he sido capaz, he leído todo lo que he podido en castellano y en ingles traduciendo en Google y me da un error y no se integra en condicionesme sale todo esto en la cabecera
    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/itsaslapurrak/itsasforo/bb-settings.php on line 186

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/itsaslapurrak/itsasforo/bb-includes/backpress/functions.wp-object-cache.php on line 108

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/itsaslapurrak/itsasforo/bb-includes/backpress/pomo/mo.php on line 171

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/itsaslapurrak/itsasforo/bb-includes/functions.bb-l10n.php on line 484

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/itsaslapurrak/itsasforo/bb-includes/backpress/class.wp-taxonomy.php on line 581

    ¿habria posibilidad de una ayudita? mientras no lo haga bien en local no pruebo en la web.
    Gracias

  • #31926

    imported_Fernando
    Participante

    Parece ser que es debido a que la versión de XAMP (o MAMP) que tienes instalada en local usa una versión distinta de php que bbPress localiza como error.

    Se puede solucionar de 2 maneras:

    1. Añadir esto al fichero bb-settings.php:
    [quote][code]if ( !defined( ‘BB_ERROR_REPORTING’ ) ) {
    define( ‘BB_ERROR_REPORTING’, E_ALL & ~E_DEPRECATED );
    }
    error_reporting( BB_ERROR_REPORTING );[/code][/quote]

    2. Añadir esto al fichero bb-config.php:
    [quote][code]error_reporting(E_ALL & ~E_DEPRECATED); ini_set(“display_errors”,”On”);[/code][/quote]

    Está anotado para solucionarlo en la versión 1.0.3.

    No obstante, es posible que en tu servidor no tengas errores que si ves en instalaciones locales.

    Referencia: http://trac.bbpress.org/ticket/1187

  • #31967

    Furia_negra
    Participante

    Gracias Fernando, pero no me fío de de no cargarme la web y luego que me de errores. detodas formas si que me ha pasado algo raro y es que al instalar el BBPress me crea los directorios MY-plugins y my-templates vacios.
    Gracias

  • #31973

    imported_Fernando
    Participante

    Es que por defecto están vacíos, es donde tienes que instalar tus plugins y themes 😉

  • #31987

    Furia_negra
    Participante

    Pero el BBpress ya trae unos bb-templates y bbplugins

  • #31991

    imported_Fernando
    Participante

    Si, en bb-templates y bb-plugins, las otras carpetas son para lo que tu añadas.

  • #32267

    simplepanas
    Participante

    Parece ser que es debido a que la versión de XAMP (o MAMP) que tienes instalada en local usa una versión distinta de php que bbPress localiza como error.
    Se puede solucionar de 2 maneras:
    1. Añadir esto al fichero bb-settings.php:
    [quote][code]if ( !defined( ‘BB_ERROR_REPORTING’ ) ) {
    define( ‘BB_ERROR_REPORTING’, E_ALL & ~E_DEPRECATED );
    }
    error_reporting( BB_ERROR_REPORTING );[/code][/quote]
    2. Añadir esto al fichero bb-config.php:
    [quote][code]error_reporting(E_ALL & ~E_DEPRECATED); ini_set(“display_errors”,”On”);[/code][/quote]
    Está anotado para solucionarlo en la versión 1.0.3.
    No obstante, es posible que en tu servidor no tengas errores que si ves en instalaciones locales.
    Referencia: http://trac.bbpress.org/ticket/1187

    en que parte tengo que poner eso, aplique lo que me dices y ahora me aparece es una pagina en blanco.

El foro ‘bbPress – TalkPress’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest

Ir al contenido