WP Pagenavi no funciona correctamente

Inicio Foros WordPress Plugins WP Pagenavi no funciona correctamente

Etiquetado: 

Este debate contiene 8 respuestas, tiene 4 mensajes y lo actualizó  Javier hace 7 años, 3 meses.

  • Autor
    Publicaciones
  • #20503

    Javier
    Participante

    <p>Un saludo a tod@s.</p>
    <p>Lo instalo y éste es el resultado visual:</p>
    <p>pagenavi.jpg</p>
    <p>¿Alguien ha pasado por lo mismo? ¿Tiene solución?</p>
    <p>¡¡¡ GRACIAS !!!</p>
    <p>Javier
    </p>

  • #50062

    Pedro Raul
    Participante

    modifica la hoja de estilo para ubicarla.

  • #50064

    Javier
    Participante

    Hola Pedro Raul.

    No, si el problema no es la ubicación o los estilos… como puedes ver en la imagen lo de “Entradas más antiguas” no desaparece.

    Gracias!

    Javier

  • #50065

    almendron
    Participante

    1) El que se vea lo de “Entradas más antiguas” es posible que no se deba al plugin. Revisa el código en busca de next_posts_link y previous_post_link.

    2) Si no estoy equivocado, el plugin WP Pagenavi necesita PHP5. Comprueba si tu servidor funciona con esa versión de PHP.

  • #50066

    Javier
    Participante

    Hola almendron.

    Te respondo:

    1) ¿Debería estar en el footer? ¿Lo elimino?

    2) Estoy usando PHP 5.3.2

    Gracias por responder…

    EDITO: Lo hago en local con MAMP.

  • #50069

    LGrusin
    Miembro

    ¿Has seguido los pasos que da la documentación del plugin?

    Para que WP-Pagenavi funcione debes añadir en cualquier lugar del archivo footer.php lo siguiente:

    Después debes configurar el plugin en Settings – PageNavi.

    Si quieres puedes modificar las hojas de estilo directamente la del plugin pagenavi-css.css (pierdes los cambios en cuanto actualices el plugin) o en las opciones de configuración.

    Existe un problema con algunos themes antiguos pero no creo que sea este tu caso.

    Un saludo

  • #50070

    almendron
    Participante

    Hola almendron.
    Te respondo:
    1) ¿Debería estar en el footer? ¿Lo elimino?

    Lo primero de todo un fe de erratas: donde puse “previous_post_link”, debía decir “previous_posts_link” (me comí la “s” final en post)

    Mira en “index.php”, “archive.php” y “footer.php”.

    En caso de estar en alguno de los dos primeros archivos, lo eliminas. De estar en el tercero, lo sustituyes por el código que te ha dicho LGrusin. Haz antes una copia de seguridad de los archivos.

  • #50089

    Javier
    Participante

    Respondo:

    LGrusin: Obviamente, en caso contrario no aparecería la paginación al pie. Uso Twenty Ten sobre WP 3.1… no se si será por culpa del tema, pero de entrada no he encontrado nada por ahí.

    almendron: En index.php no hay rastro, en archive.php tampoco… y en footer.php, tampoco. He buscado en todos los archivos y no hay ninguna cadena de texto como la que indicas ¿? Todo esto desde Apariencia > Editor… estoy confundido.

    Javier

  • #50094

    Javier
    Participante

    SOLUCIONADO:

    – Los códigos de navegación “Entradas más antiguas” “Entradas más nuevas” no se guardan en index.php, archive.php o footer.php (sí en versiones más viejas) sino el loop.php, justo al final del archivo.

    – Una vez eliminado el mismo desparecen los enlaces. Ahora a tocar el CSS para darle el toque final.

    Muchas gracias a Pedro Raul, almendron y LGrusin por responder y orientarme.

    Javier

El foro ‘Plugins’ está cerrado y no se permiten nuevos debates ni respuestas.

Pin It on Pinterest