Respuesta a: Problema permalinks y error 404

Inicio Foros WordPress General WordPress.org Problema permalinks y error 404 Respuesta a: Problema permalinks y error 404

#52348

sebas_acci
Participante

Os doy más pistas, no voy a parar de calentarme la cabeza hasta que consiga solucionar el problema :-8

Creo que el problema está en el archivo .htaccess. Originariamente, con los permalinks por defecto el .htaccess tiene esta info:
[quote]# BEGIN WordPress

# END WordPress[/quote]

Cuando activo los permalinks a “/%postname%/” el .htaccess cambia a:
[quote]# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress[/quote]

Esta linea es un poco rara, pero aunque la borre el problema no se soluciona, asi que no creo que sea debido a eso:
[quote]RewriteRule ^index.php$ – [L][/quote]

Bueno, pues si una vez activados los permalinks a “/%postname%/” cojo y borro del .htaccess toda la info nueva, lo dejo como si no hubiera cambiado los permalinks, es decir:
[quote]# BEGIN WordPress

# END WordPress[/quote]

Si hago esto, me deja abrir si problemas el MySQLdumper:
http://www.sebastian-perez.com/msd/
pero ahora no puedo ver los post, me da error 404, por ejemplo este:
http://www.sebastian-perez.com/bienvenidos-a-mi-blog/
Algo lógico puesto que el archivo .htacccess no tiene la info necesaria para eso.

A lo mejor no he avanzado demasiado, pero creo que el problema va a estar en la info del archivo .htaccess, ¿que creeis? :S

Pin It on Pinterest

Ir al contenido