Respuesta a: Plugin para corregir la vulnerabilidad del Timthumb

Inicio Foros WordPress Plugins Plugin para corregir la vulnerabilidad del Timthumb Respuesta a: Plugin para corregir la vulnerabilidad del Timthumb

#55278

imported_j.conti
Participante

Los archivos que tienes que buscar se pueden llamar de dos formas diferentes:

timthumb.php
thumb.php

Descárgalos a tu ordenador y abrelo, utiliza un soft como este: http://www.geany.org/ si tienes otro que REALMENTE no te corrompa los archivos, úsalo, pero este que te presento es muy bueno.

Luego mira en la cabecera la versión, verás que está una vez pasada la introducción del archivo.

define ('VERSION', '2.8');

La versión debe ser la 2.8 o superior, todas las inferiores están afectadas.

El archivo que debes descargarte es este:

http://timthumb.googlecode.com/svn/trunk/timthumb.php

Copia todo el contenido de lo que verás y creas uno nuevo y lo subes. Repito, cuidado con el software que edición que usais y os recomiendo de nuevo el Geany.

Y ya está.

Sobre todo, por si las moscas, realizar una copia de seguridad y guardar vuestros antiguos archivos, que nunca se sabe lo que puede pasar.

Salu2

Pin It on Pinterest