Respuesta a: No abre las categorías al actualizar a la 3.3

Inicio Foros WordPress Instalación / Actualización No abre las categorías al actualizar a la 3.3 Respuesta a: No abre las categorías al actualizar a la 3.3

#59014

kloker
Participante

Hola de nuevo,

He probado lo que me ha comentado almendron y sí que me funciona. Mientras que lo que me has comentado tú, LGrusin, y me funcionan los posts y páginas pero las categorías siguen sin funcionarme.

El contenido del .htaccess después de los cambios es:

SetEnv PHP_VER 5
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Por cierto, si lo dejo lo de enlaces permanentes en predeterminado (osea, por defecto), me funcionan bien las categorías y todo. Pero después poner /%post_id%/%postname%.html me vuelve a suceder lo mismo.

Lo de que algunas categorías funcionan y otras categorías no funcionan, no es del todo así…
Las que no funcionan por completo, me salta la página de error 404, mientras que las que aparentemente funcionan, no lo hacen correctamente, ya que me deberían de mostrar un listado de los posts de esa categoría, pero no lo hacen, me muestra un post de esa categoría (creo que el post que muestra suele poseer en el título la palabra del nombre de la categoría -esto lo comento por si se os ocurre el motivo). En el menú de arriba (header), no todo lo que aparece ahí son categorías, también hay páginas (y las páginas sí que funcionan todas bien), por lo que realmente las categorías (para que no os lieis) son todas las que aparecen en el sidebar.

Gracias de nuevo

Pin It on Pinterest