Reply To: Pasar de PHP4 a PHP5 , ¿Riesgos?

Inicio Foros WordPress Programación Pasar de PHP4 a PHP5 , ¿Riesgos? Reply To: Pasar de PHP4 a PHP5 , ¿Riesgos?

#61122

Hombre Man
Participante

El error que mencionas es un error de sintaxis…

Pero en fin. Tu proveedor de hosting debe instalar primero en el servidor el programa en la versión que necesitas.

Más aún, en los servidores de muchos proveedores de hosting, coexisten ambas versiones y la empresa te proporciona los medios para cambiar de versión, que en muchos casos se hace con directivas de mime/type… pero supongo que con setenv también es posible.

Por otro lado, las buenas prácticas de programación recomiendan que te cambies a la versión más reciente, y una de las principales razones es la seguridad. Pero poco a poco verás que los sistemas abandonan poco a poco PHP4, y tu código corre el riesgo de obsolescencia.
Entonces los riesgos son esos dos: falta de seguridad y obsolescencia. Y ambos riesgos podrían aparecer si no cambias a PHP5.

Pin It on Pinterest