Miles de webs rotas tras actualizar a WordPress 4.5

Los últimos días, desde la actualización de WordPress 4.5, se ha llenado la red, y sobre todo los foros de soporte de WordPress, de quejas de usuarios cuyas webs se habían roto al actualizar a esta nueva versión, achacando a WordPress sus sufrimientos, pero resulta que no era WordPress el culpable, mira por donde.

Hay algún caso por ahí peculiar, pero en la inmensa mayoría de los casos, las webs rotas no han sido por culpa de WordPress, sino de un plugin no actualizado: Visual Composer.

web rota

¿Resultado? Decenas de miles de webs rotas en todo el mundo al actualizar a WordPress 4.5, y que el artículo más visitado de la última semana haya sido el de cómo volver a una versión anterior de WordPress.

Entonces ¿es Visual Composer malo? … pues tampoco, y me explico.

El problema está en que la mayoría de los temas premium que se venden en mercados como ThemeForest en realidad deben gran parte de su magia precisamente a que incorporan en la descarga el plugin Visual Composer, un maquetador como Divi, por ejemplo, con el que al final es con el que los usuarios crean sus páginas, portada y muchos más contenidos.

Luego, claro, es un plugin que no podemos desactivar, y esa es parte de la parte negativa de los maquetadores visuales como ya comenté en su día.

Pero tampoco ha sido ese el problema.

El problema fue que el usuario normalmente no es consciente de que debe actualizar también Visual Composer, porque no siempre los desarrolladores de temas añaden licencia de Visual Composer en sus temas, simplemente regalan la versión vigente en el momento de la compra.

Nadie cae en cómo es posible que un tema que vale 40$ incluya un plugin que por sí solo cuesta 34$, eso son fruslerías ¿no? Pues no, resulta que lo que hace especiales a los temas, lo que hace que las demos que nos muestran sean tan fantásticas es precisamente un uso inteligente del maquetador visual.

visual composer instalado y activo

Y claro, el usuario, sin avisos que le digan que tiene algo mal, actualiza WordPress y … ¡oh casualidad! resulta que en la versión 4.5 de WordPress si que se avisó de que habría problemas en ciertos plugins, como ha sido el caso.

Pues bien, el resultado ha sido que el usuario que tenía su licencia de Visual Composer, además de la del tema, recibió un aviso el día antes de salir a la luz WordPress 4.5 para que actualizase el plugin, pero el resto, medio planeta, actualizó a WordPress 4.5 sin información suficiente y el resultados fue algo así …

web rota por visual composer

Y luego claro, luego está el tema de las licencias…

Son muchas veces las que oigo que nada mejor que las licencias de por vida de ThemeForest o cualquiera de los mercados de Envato, porque son de por vida, pero es que es falso.

descargar visual composer

Lo que es de por vida es la licencia para descargas, pero no el soporte, que casi nadie renueva, así que cuando tienes un problema con tu plugin o tema de pago ¿a donde vas? … a los foros de soporte de WordPress en Español, para recibir una amable respuesta – y lógica – del tipo:

Lo sentimos pero los voluntarios de WordPress no damos soporte sobre plugins y temas de pago porque con la licencia debes requerir ese soporte y, además, no tenemos acceso a todos los plugins y temas de pago gratuitamente como para conocerlos lo suficiente y poder ayudar en caso de problemas

¿A que tiene lógica?

Y no, este error no solo ha afectado a sitios creados con Visual Composer + el tema loquesea, pero su relevancia ha sido enorme debido a su gran implantación.

Pues eso, que tomes nota, por favor:

  1. Si adquieres un tema que incluya algún plugin asegúrate de que tienes la licencia de ambos si fuesen de pago.
  2. En caso contrario adquiere una licencia del plugin que incluya las actualizaciones.
  3. Elige siempre temas y plugins con un historial de actualizaciones fiable y constante.
  4. Si eres desarrollador de plugins o temas para WordPress estate atento a http://make.wordpress.org para estar al día de los cambios de WordPress, por si tuvieses que actualizar tu plugin/tema y no dejar tirados a tus usuarios (no digamos si es de pago)
  5. Nunca dejes de actualizar WordPress por un plugin o tema abandonado por su desarrollador, antes cambia de plugin o tema y ten tu web segura.
  6. Suscríbete a Ayuda WordPress para estar al día de todas las novedades sobre WordPress.

¿Y tú, has tenido problemas con la actualización a WordPress 4.5?

Yo uso Visual Composer en bastantes webs, propias y de clientes, y también Divi como ya sabrás, pero no he tenido ningún problema, básicamente porque procuro estar informado, por responsabilidad hacia mis clientes, y por puro sentido común.

Una de las bellezas del software libre es que la información y el código están siempre disponibles, así que sería estúpido no mantenerte al día, mucho menos si eres desarrollador ¿no te parece?

¿Y tú que tal, algún problemilla?


(Nota: por si no te has dado cuenta algunos de los enlaces que hay en esta entrada son de afiliación, de modo que si adquieres algún producto a ti te cuesta lo mismo pero a mi me pagas un café) 

VALORA Y COMPARTE ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
(43 votos, promedio: 4.4)

¿Te gustó este artículo? ¡Ni te imaginas lo que te estás perdiendo en YouTube!

AVISO: Esta publicación es de hace 3 años o más. Si es un código o un plugin podría no funcionar en las últimas versiones de WordPress, y si es una noticia podría estar ya obsoleta. Luego no digas que no te hemos avisado.

44 comentarios en “Miles de webs rotas tras actualizar a WordPress 4.5”

  1. El titular es un poquito sensacionalista eh, conduce a equívocos Fernando y además da mala publicidad a WordPress 4.5 pero bueno, tú sabrás.

    Yo afortunadamente uso ‘Page Builder por SiteOrigin’ (convenientemente actualizado), del que hablaré próximamente. Lo utilice para maquetar debidamente mi web que la tenía un poco abandonada en ese aspecto.

    No recomiendo normalmente utilizar este tipo de plugins/herramientas para post/artículos, pero sí, para páginas.

    Bueno, se agradece el aviso e información extra.

    Saludos.

  2. Lorenzo Solís

    Hola,

    A mi también se me ha ‘roto’ la web al actualizarse automáticamente WP a la 4.5

    Pero! Yo no utilizo Visual Composer y todavía me pregunto qué ha podido ser.

    Gracias por compartir

  3. En mi caso, desde mi experiencia digo que en el artículo falta mencionar que los Templates de Envato, si bien su actualización no va de la mano necesariamente con las versiones de WP, muchos de los desarrolladores publican con desfase sus plugins actualizados. Así que antes de actualizar, yo espero que ésta última versión del desarrollador y la que siempre tarda es justamente la de Visual Composer.

  4. Yo utilizo Divi y actualice primero wp y despues cuando lo intente con Divi me dio error. Resultado todas las imagenes en movimiento desaparecieron de la vista web. No tuve mas remedio que volver a la version anterior. Cuando consiga actualizar divi ya no se si probar suerte con wp. No llevemo mucho en wordpress y me da un poco de reparo. Un saludo.

    1. En el soporte de Elegant themes avisaron que ya se había solucionado el problema con Divi. Yo había actualizado a wordpress 4.5 y las aplicaciones fallaron, recargué la versión anterior del WP y todo ok de nuevo. Luego del aviso de ET actualicé nuevamente y ha funcionado a la perfección.

      1. Pero es que ahora resulta que me da error al actualizar divi porque o carga un determinado archivo. Los de ET me dicen que desactive unos plugins que junto no tengo instalados. Así que me quedo como estoy …de momento. Gracias por el aporte.

  5. Yo tuve un problema al principio, me daba un error «SET PASSWORD», pero era porque al parecer la versión más actual de PHP, la 5.6.19, da problemas.
    Fue cambiar a la 5.5.33 y desapareció el error.

    1. Yo uso PHP 7 en casi todos mis sitios y sin problema. De hecho me parece un error desactualizar algo tan importante como PHP sin mirar otras posibles causas.

      1. Yo lo probé todo, desactivé themes y plugins y nada, seguia ocurriendo.

        Cree otra instalación en una subcarpeta para verificar y no funcionaba. Me contacte con el servicio de atencion de mi hosting y probaron varias cosas hasta que cambiaron la version de PHP y todo volvió a la normalidad.

        ¿qué pudo haber sido?

  6. Yo he sido uno de los afectados, y, si te soy sincero, si que tras actualizar a 4.5 te quedas «flipando», pero bueno, me costó actualizar visual composer y un plugin media hora, así que el susto no fue para tanto. Al tratarse de un tema de pago, opino que no debería de haber estos lios, pero en fin, es lo que hay. Las webs me seguían funcionando, pero no se podía editar ninguna página creada con el composer. Lo dejaremos como un susto y listo, esperemos que en la próxima actualización no se lie de nuevo.

    De todas formas, a lo que se tendría que acostumbrar la gente es a hacer un backup de sus sitios antes de actualizar de versión de wp, así si hay que volver atrás no hay problemas, que para eso hay un montón de opciones…

  7. Yo utilizo Visual Composer y al actualizar no se «rompió» nada pero no podía editar las páginas con VC. Una vez que actualizas a la versión 4.11.2 de VC ya funciona correctamente.

    Lo ideal es lo que comentas, tener la licencia del plugin, porque si tienes que esperar a que los desarrolladores de la plantilla actualicen la versión de VC pueden pasar semanas…

    Un saludo.

  8. Es tan triste como cierto…. me ha pasado exactamente lo que describen. Por suerte, el desarrollador del theme que tengo me hizo un parche u algo, y reparó el gran fallo del VC… La gente de VC… bien gracias! pasan los días y no dan solución…

  9. En realidad lo que ha pasado, por lo menos en mi caso.. es que las webs que tengo con VC no han dejado de funcionar como tal.. Mas bien han dejado de actualizar VC.. Y claro que era un problema. Pero la solución se encontraba rápida al leer el soporte del plugin, era algo asi como: «si tu plugin venía con un tema, desinstala el plugin, actualiza el tema, y se descargará automáticamente la última versión desde la sección de plugins».

    Es verdad que el susto fue tremendo al ver que no podía actualizar ni modificar contenido por que el plugin había dejado de funcionar, pero como digo.. Trasteando un poquito se soluciona fácil.. Por lo menos en temas premium..

    Lo de que el soporte, sean solo seis meses es un tema aparte…

  10. Totalmente de acuerdo con el artículo. No se puede explicar mejor. Luego vemos como se venden webs por 150 € que hacen de todo. En fin, hallá cada cual con su conciencia, pero soy de la opinión que siempre merece hacer las cosas bien desde el principio y evitar este tipo de problemas.
    Saludos

  11. Muchas gracias por la info que brindás. Sabés que hace poco yo tmb descubrí que Evanto no te dá soporte de por vida, como yo había pensado. Cdo tuve un problema y quise preguntar algo en el foro, me pasó exactamente lo mismo. Después de un año tenía que renovar la licencia y pagar por ello, obviamente. Tmb me pareció un absurdo y eso lo tendré en cuenta para la próxima plantilla que compre para mi blog. Slds.

  12. La verdad que a nosotros nos ha afectado bastante porque solemos trabajar con Visual Composer y ahora no va. Nuestra elección ha sido esperar a que WordPress actualice a la versión 4.5.1 y a ver si así volvemos a trabajar con normalidad.

    Gracias por el post!

    Un saludo!

  13. Pingback: EP#13: Traducir WordPress, trucos para one-page sites y lo mejor de la semana - Juan Hernando – ciudadanoB

  14. Pingback: Wordpress, la operación bikini y los Cazafantasmas

  15. Hola Fernando,

    Yo soy una de las afectadas aunque no utilizo Visual Composer. Mi problema radica en que la actualización de WordPress y la de mi tema (Customizr) tienen algún tipo de incompatibilidad, aunque desde Customizr digan que es 100% compatible. Utilizo Thrive Visual Editor (de pago) y ellos dicen que es un error de CSS del tema.
    Llevo varios días así y nadie me da una solución. Ni desde WordPress ni desde Customizr ni, evidentemente desde Thrive, que ya me han dicho que no pueden hacer nada.

    Lo que me parece increíble es que a cada actualización, por mucho cuidado que tengas, pueda ocurrir algo que se lleve al traste todo tu trabajo y nadie lo solucione.

    Magnífico post.

    Salva

  16. Hola, mi web tiene ese problema si uso composer, me genero problema con este plugin Mega Main Menu pues instale otro mientras lo soluciono pero aun no lo logro sera que me pueden ayudar.

  17. Pingback: Los papeles de Panamá y WordPress - RTF Procuradores

  18. Yo por eso no me gusta comprar temas de pago o utilizar temas que requieren de un plugin externo para funcionar. Me parece utilizar algo que está mal hecho. Y no se si me equivoco pero tampoco cumplen el código de buen desarrollo de temas. Para elegir un tema, en mi opinión no solo debe tener buena fachada (ser bonito) si no que debe tener un buen diseño claro y conciso (un buen código, vamos).

  19. Pingback: Divi 3.0 usará ReactJS para la maquetación en portada

  20. Singular GDesign

    Una información muy útil!
    Entonces, si tenemos este problema, ¿qué recomiendas?, ¿si compramos el plugin estará solucionado?

  21. Prefiero hacer pruebas en local antes de aplicar cualquier tipo de cambio a mi sitio original, es mejor prevenir a luego lamentarse.

  22. María J. Henche

    Hola, yo tengo el tema trinity de The Theme Forest, he actualizado el plugin previo pago, y no consigo que funcione.
    Desde el plugin me remiten al creador del tema. El creador del tema me dice que si no tengo la orden de compra no me atiende. Y la orden de compra está vaya usted a saber donde, ya que la página la creo una agencia que a día de hoy, no está operativa.

    ¿Alguna idea?

  23. Elena González Tojeira

    Hola Fernando, tengo el mismo problema que muchos de los que escriben aquí. Mi tema es de Theme Forest y ahora con la actualización tengo problema con el visual composer.
    Que me aconsejas?
    Muchas gracias

  24. Hola! yo he actualizado hoy y me ha dejado de funcionar todo. De hecho ni la web carga ni puedo acceder a la administración ni nada. MI tema es Aurum y ha ocurrido al actualizar wordpress y woocommerce. ¿qué puedo hacer?

  25. Pingback: El peligro de las actualizaciones en Wordpress - Pack WordPress

  26. Pingback: El peligro de las actualizaciones en Wordpress - Frikymama

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

 

Ir arriba Ir al contenido