Cómo volver a los widgets clásicos después de WordPress 5.8

WordPress 5.8, con lanzamiento previsto en julio de 2021, tendrá entre otras muchas novedades, un nuevo modo de gestión de widgets, basado en bloques, como el editor de WordPress.

Crear áreas de widgets y añadir nuevos widgets será igual de sencillo que añadir bloques a una entrada o página, lo que abrirá un mundo de nuevas posibilidades en forma de bloques que incorporar en nuestras áreas de widgets.

Ahora bien, habrá a quien no le guste en principio este nuevo modo de gestionar widgets, o que descubra que su tema activo no es compatible con este nuevo sistema de gestión de widgets.

Para estos casos se ha desarrollado el plugin Classic Widgets, cuya funcionalidad es devolver el antiguo modo de gestión de widgets, el tradicional o clásico.

El plugin no tiene ajustes, solo tienes que activarlo y volverás a la antigua gestión de widgets, a los widgets clásicos.

Si ya tenías algún bloque insertado en un área de widgets, WordPress 5.8 lo identificará como un – – nuevo – widget de bloque, respetando la configuración existente.

Igualmente que, si actualizas a WordPress 5.8 y tenías widgets previamente, los identificará como widgets heredados, respetando también sus ajustes.

Vamos, que este no será el cambio más doloroso tras actualizar a WordPress 5.8, pero como siempre tienes la posibilidad de revertir funcionalidades a las «clásicas».

Si lo prefieres, también puedes desactivar la gestión de widgets como bloques con un código, que puedes añadir a tu plugin personalizado o al archivo functions.php del tema, este:

// Desactiva el editor de bloques en la gestión de widgets.
add_filter( 'use_widgets_block_editor', '__return_false' );

El resultado es el mismo que con el plugin.

(3 votos, promedio: 5) Valora este artículo para ayudar a mejorar la calidad del blog

¿Te gustó este artículo? ¡Ni te imaginas lo que te estás perdiendo en YouTube!

Sobre el autor

4 comentarios en “Cómo volver a los widgets clásicos después de WordPress 5.8”

  1. Gracias por el post. Llevo toda la tarde volviéndome loca para encontrar el problema que había. Otro problema que tengo con los bloques es que no son compatibles con polylang. Tengo una página en dos idiomas y no puedo seleccionar en que idioma se muestra el widget. Intentaré activar el plugging classic widget. Espero lograrlo. Gracias de nuevo 🙂

  2. Muchas gracias. Me sirvió. Me resulta poco amigable, y todavía menos práctico, el sistema de bloques de WordPress. Agradecida de la información.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Información base sobre privacidad:
  • Responsable: Fernando Tellado ([email protected])
  • Fin del tratamiento: Moderación de comentarios para evitar spam
  • Legitimación: Tu consentimiento
  • Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal
  • Derechos: Acceso, rectificación, portabilidad, olvido

 

Ir arriba Ir al contenido