WordPress 5.0 – Todas las novedades y dudas razonables antes de actualizar

Ni diré para cuando está previsto el lanzamiento de WordPress 5.0 porque ni el equipo de desarrollo lo sabe. Podría salir mañana, dentro de una semana o un mes, pero da igual.

Es lo mismo cuando salga a la luz WordPress 5.0, lo que está claro es que será Gutenberg sí o sí.

Dicho esto, vamos a ver qué nos traerá WordPress 5.0, salga cuando salga.

¿Qué novedades trae WordPress 5.0?

Se pueden resumir muy fácilmente las novedades de WordPress 5.9, en concreto en 2:

  1. El nuevo editor de bloques Gutenberg
  2. El nuevo tema por defecto Twenty Nineteen

El nuevo editor de bloques Gutenberg

Mucho se ha hablado, y lo que queda, sobre el nuevo editor de bloques llamado proyecto Gutenberg, pues es un sustituto del editor clásico TinyMCE, con lo que esto conlleva de cambio en la forma de trabajar con WordPress.

Durante todo el año 2018 se ha desatado la rumurología, las quejas por el modo de tomar las decisiones en WordPress 5.o, más la polémica por los problemas del nuevo editor con la accesibilidad y con la compatibilidad con plugins.

Si te interesa todo lo relacionado con la polémica sobre Gutenberg te recomiendo ver mi ponencia en WordCamp Granada, que trató expresamente sobre todo lo que ha ocurrido al respecto…


¿Pero de qué se trata?

Pues de un nuevo editor basado en bloques de contenido, que poco a poco irán sustituyendo otros aspectos de WordPress, pues está previsto que en sucesivas fases también los menús, widgets e incluso diseño de portada sea mediante bloques.

Básicamente, pasar de esto…

A esto otro…

Que, en acción, es así:

Ventajas e inconvenientes del editor de bloques

Mucho se ha hablado de lo que pueda suponer este cambio, pero te lo resumo:

  • Desarrollo en React, una biblioteca JavaScript, que forzará a los programadores de WordPress a aprenderla.
  • Nuevo flujo del modo de trabajo, también en las combinaciones de teclas, lo que obligará a todos los usuarios a aprender cómo utilizar el nuevo editor, aumentando la curva de aprendizaje.
  • Multitud de plugins incompatibles con el nuevo editor de bloques, lo que va a frenar su implantación.
  • Problemas de accesibilidad, que impedirán que muchas webs se actualicen, para no dejar abandonados a usuarios con necesidad de tecnologías de asistencia e incluso por cuestiones legales.
  • Los bloques son agnósticos de la aplicación al estar creados en JavaScript, por lo que se generará un gran mercado de bloques, utilizables en distintos CMS.

Por otra parte, los temas no tendrán problemas con los bloques, pues salvo que quieras incorporar novedades de diseño, todos los temas son compatibles con Gutenberg.

En el caso de incompatibilidades con plugins, necesidad de accesibilidad o curva de aprendizaje, la misma instalación de WordPress 5.0 anima a instalar el editor clásico como plugin, para garantizar la transición.

Parece que, al menos, el equipo de desarrollo es consciente de que WordPress 5.0 puede generar problemas, y se cura en salud animando a instalar el editor clásico, aunque esto contradiga la filosofía de WordPress

«Limpio, ágil y genial

… Si la próxima versión de WordPress viene con una característica que la mayoría de los usuarios inmediatamente quieren desactivar, o piensan que nunca usarán, entonces nos hemos equivocado.»

 

«Accesibilidad

… Todas las nuevas actualizaciones del código de WordPress deben cumplir estas directrices y los estándares de accesibilidad en la programación de WordPress.»

El nuevo tema por defecto Twenty Nineteen

Hasta última hora no estaba previsto que con WordPress 5.0 hubiese un tema nuevo pero se decidió incorporar un tema que ya fuese totalmente compatible con los nuevos bloques del editor Gutenberg, para seguir con la tradición de WordPress de incluir un tema adaptado a las nuevas versiones.

El nuevo tema WordPress por defecto, Twenty Nineteen tiene un diseño muy minimalista, quizás por el poco tiempo en el que se ha desarrollado.

Básicamente es un tema con estructura de ancho completo, sin barras laterales, con  una gran zona de cabecera y área de widgets en el pie de página.

De paso, todos los temas por defecto anteriores también se han actualizado para que sean compatibles con los estilos de los bloques del editor Gutenberg.

¿No hay más novedades en WordPress 5.0?

Aparte de estas dos cosas poco más, que se puede resumir en lo siguiente:

  • Compatibilidad con PHP 7.3
  • Mejoras en la REST API
  • Nueva API de bloques, lógicamente
  • Nueva API de avisos, para incorporar mensajes emergentes en los bloques
  • Mejoras de seguridad
  • Mejoras en la adaptabilidad a móviles
  • Mejoras en el recorte de imágenes de fondo

Cómo y cuándo actualizar a WordPress 5.0

Visto todo lo anterior, como siempre, tú decides cuando actualizar a WordPress 5.0, pero mi consejo es – y no soy el único – que, vista la precipitación, retrasos, polémicas, incompatibilidades y cambios de modo de trabajo te tomes un tiempo antes de hacerlo, especialmente si aún no has probado Gutenberg en tu sitio actual.

Y no vale que hayas probado el plugin Gutenberg, pues cosas que funcionaban con el plugin Gutenberg no funcionan en el editor de bloques integrado en WordPress 5.0, y viceversa.

Antes de actualizar crea una instalación con tu tema y todos tus plugins actuales, o haz una copia, y comprueba de manera exhaustiva si todo funciona como se espera.

Solo tras haber comprobado que ni tus plugins ni tu tema, no digamos tu eCommerce si lo tienes, funciona correctamente. De hecho, si usas WooCommerce se recomienda encarecidamente actualizar a WooCommerce 3.51 antes de cambiar a WordPress 5.0.

Una vez realizadas las pruebas, cuando te hayas decidido, el método para actualizar a WordPress 5.0 sería el siguiente:

  1. Haz una copia de seguridad completa de la base de datos y los contenidos.
  2. Instala el plugin “Classic Editor” para garantizar que no se perderá ninguna parte de tu contenido, y poder decidir siempre si quieres usar en cada entrada el editor clásico o el de bloques.
  3. Instala el plugin “Gutenberg Ramp” para poder configurar a qué tipos de contenido afectará o no el editor de bloques.
  4. Actualiza a WordPress 5.0 y vuelve a comprobar que funciona todo.

Lo anterior son soluciones intermedias, pero si tienes claro que no vas a utilizar el editor de bloques Gutenberg instala y activa el plugin No Gutenberg y solucionado, sin necesidad de ajustes.

¿Y los maquetadores visuales? ¿Cómo les afecta el editor de bloques?

La realidad es que el editor de bloques no hace ni que se despeinen los actuales maquetadores visuales, con muchas y más avanzadas características que lo que ofrece Gutenberg.

Así que, de momento, y me temo que por mucho tiempo, maquetadores como Divi o Elementor tienen mucha vida por delante, pues permiten algo que Gutenberg no ofrece: diseñar y crear portadas, landing y páginas impresionantes a golpe de clic.

Bienvenido al apasionante mundo de los bloques

Nos queda aún mucho por ver sobre cómo va a afectar el tremendo cambio que supone WordPress 5.0, tanto en el modo de trabajar como en la filosofía de todo el proyecto, pero lo que está claro que es que ahora nos toca aprender a usar bloques.

Durante semanas he estado publicando artículos para ayudarte a aprender a usar y mejorar el nuevo editor de bloques Gutenberg, repásalos y adéntrate en el apasionante mundo de los bloques.

VALORA ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
FlojitoNo está malEstá bienMe ha servidoFantástico (20 votos, promedio: 4,60 de 5)
Cargando…

Autor: Fernando Tellado

Fernando Tellado, apasionado de WordPress, profesor, consultor y ponente. Maquero cansino, padre de tres hijos y de una perrita Beagle, Bilbaíno de nacimiento, Español de corazón y ciudadano de donde me quieran. Autor del libro WordPress - La tela de la araña. Mi blog personal es Navegando con red, donde he crecido como escritor en la red y ofrezco mis visiones acerca de la Web 2.0 y la blogosfera.

Comparte esta entrada en
468 ad

Centro de preferencias de privacidad

Cookies imprescindibles

Se usan para saber si ya aceptaste nuestras políticas, si ya estás suscrito a nuestra newsletter, para reconocer el estado de tu sesión si la tuvieses y para servir más rápidos los contenidos.

No se captura IPs ni siquiera para el servicio de Analytics así que tu visita es privada.

JSESSIONID, _cfuid, wpSGCachePypass, mailerlite, gdpr, gawp
mailerlite, _cfuid

Cookies de terceros

Usamos cookies de terceros con servicios, también garantes de tu privacidad, que analizan tus usos de navegación para que podamos mejorar los contenidos, si ya estás suscrito al boletín y los elementos compartidos en redes sociales y el formulario de comentarios.

1P_JAR, APISID, CONSENT, HPSID, NID, SAPISID, SID, SIDCC, SSID, disqus_unique, disqusauth
disqus_unique, disqusauth
1P_JAR, APISID, CONSENT, HPSID, NID, SAPISID, SID, SIDCC, SSID

Pin It on Pinterest

Share This
Ir al contenido