Como quitar el aviso de actualización de WordPress

aviso-update-wp.png

Una de las cosas mas tontas que tiene WordPress desde la versión 2.3 es el sistema, espía para algunos, de avisarte de las nuevas actualizaciones disponibles del CMS. Y digo que es tonto porque ya tienes en el Tablero la información acerca de las novedades.

novedades-desarrollo-wp.png

Pues bien, si quieres quitar ese molesto aviso de tu panel de administración, y actualizar cuando tu quieras sin necesidad de que te lo recuerden, solo debes realizar estos dos pasos:

1. Abrir el fichero wp-settings.php y comentar la línea

require (ABSPATH . WPINC . '/update.php');

para que quede de este modo …

#require (ABSPATH . WPINC . '/update.php');

2. Abrir el fichero /wp-admin/includes/admin.php y comentar la línea

require_once(ABSPATH . 'wp-admin/includes/update.php');

para que quede así …

#require_once(ABSPATH . 'wp-admin/includes/update.php');

Si además quieres que tampoco te avise de las actualizaciones de los plugins instalados deberás editar el fichero /wp-admin/includes/update.php de modo que donde pone …

add_action( 'load-plugins.php', 'wp_update_plugins' );

dejarlo como …

#add_action( 'load-plugins.php', 'wp_update_plugins' );

Ya está. Ahora solo tienes que revisar las páginas de tus plugins favoritos de vez en cuando para comprobar si alguna actualización merece la pena, que WordPress ya te avisará en el Tablero cuando haya versiones nuevas, o te enterarás leyendo Ayuda WordPress o suscribiéndote a nuestro feed.

Vía | Jaroche y anieto2k

VALORA Y COMPARTE ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
(2 votos, promedio: 2.5)

¿Te gustó este artículo? ¡Ni te imaginas lo que te estás perdiendo en YouTube!

AVISO: Esta publicación es de hace 3 años o más. Si es un código o un plugin podría no funcionar en las últimas versiones de WordPress, y si es una noticia podría estar ya obsoleta. Luego no digas que no te hemos avisado.

10 comentarios en “Como quitar el aviso de actualización de WordPress”

  1. A mi hasta ahora no me molestaba el mensajito pero la última actualización (2.2.3 creo que era) sólo he actualizado el php que tenía la vulnerabilidad y claro, se me ha quedado el mensaje ahí puesto. ¿En dónde tiene WP guardado el dato de en qué versión está mi copia para compararlo con la última versión? porque en mi caso preferiría tocar eso a mano.

  2. El número de versión está en wp-includes/version.php 😉

    La verdad es que no he probado si funciona igual cambiando el número ahí. Coméntame si es así y actualizo el post para incluir esa opción 🙂

  3. Si estas usando la versión 2.8.3 ademas debes de editar el archivo wp-admin/includes/dashboard.php y comentar la linea

    update_right_now_message();

    para que quede así

    #update_right_now_message();

  4. esto en realidad no funciona si es verdad que te quita el aviso de la parte superior pero tanvien te quita el aviso amarillo de los plugin y eso no me interesa quitarlo saveis de alguna otra forma que solo elimine el cartel amarillo de la parte superior???

  5. hola, por si a alguien le sirve, lo que yo hago es modificar los valores de:
     #update-nag,.update-nag que se encuentran en los ficheros:
    wp-admin/css/colors-fresh.css
    wp-admin/css/wp-admin.css  
    el texto a 0px, el fondo y borde blanco.
    No sé si es una buena solución pero funciona.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

 

Ir arriba Ir al contenido