El Editor Visual no Funciona – Solución

Hay ocasiones en que al actualizar WordPress o cambiar de alojamiento descubres que no te aparece el editor visual tiny_mce, el estándar de WordPress, en su entrada de posts. Dicho problema se debe a una incompatibilidad entre WordPress 2.2 o superior con las versiones de PHP superiores a 5.2.1. Dicha incompatibilidad provoca que desaparezca el editor visual tiny_mce, lo que imposibilita su uso.

La solución es editar el archivo wp-includes/js/tinymce/tiny_mce_gzip.php para añadir una arroba (@) delante de la función realpath(), ya que esta es la que lanza un error y imposibilita que se cargue el editor. Te sale algo así de feo …

problema-tinymce-visual.png

Si eres un fiera del código puedes desmarcar en tu Perfil de Usuario la opción de «Usa el editor visual» pero en cualquier caso se puede solucionar.

Para solventar dicho problema, por favor, sigue los siguientes pasos:

  1. Descarga el archivo wp-includes/js/tinymce/tiny_mce_gzip.php.
  2. Editarlo con algún editor de texto.
  3. Ve a la línea 195 y busca: $path = realpath($path);.
  4. Añade una arroba (@) delante de «realpath».
  5. Ahora la línea 195 figura así: $path = @realpath($path);.
  6. Guarda los cambios y sube el archivo al mismo sitio donde lo descargaste.

Una vez haya seguido esos pasos, verás que ya te aparece el editor visual.

Si sigue sin funcionar, tambien hay que modificar esto (en el mismo archivo mencionado arriba):

Busca una linea (es unica) que diga así

$supportsGzip = true;

Hay una igual que dice «= false», pero más abajo hay otra que dice «= true». Cuando la encontramos cambiamos ‘true’ a ‘false’. Después la subimos otra vez al directorio (obviamente sobreescribiendo) y ya anda.
(gracias Marcelo)

VALORA Y COMPARTE ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
(3 votos, promedio: 3.7)

¿Te gustó este artículo? ¡Ni te imaginas lo que te estás perdiendo en YouTube!

AVISO: Esta publicación es de hace 3 años o más. Si es un código o un plugin podría no funcionar en las últimas versiones de WordPress, y si es una noticia podría estar ya obsoleta. Luego no digas que no te hemos avisado.

67 comentarios en “El Editor Visual no Funciona – Solución”

  1. Buenas,

    Buscando como un loco por internet he topado con esta web y creo que en un futuro me sera de gran ayuda ya que acabo de empezar con el WordPress.

    Queria aprovechar esta entrada para comentar un problema que tengo y el cual me está volviendo loco.

    Hace 2 semanas instale WP y por buscarlo en español instalé una version muy antigua, 2.0.5. Al intentar instalar la galeria nextgen descubrí que tenia una version muy antigua e instale la version 2.3.2, instale un par de traducciones y ninguna me funiona…pero este no es problema.

    El tema es que con la version que tenia antes, los botones que salian de edicion a la hora de crear una entrada en modo visual eran tipo «word» y con la version 2.3.2 son botones como «con codigo» y por ejemplo, cuando insertaba una imagen se abria un pop-up en el que introducia la url de la imagen, la descripcion de la imagen y en el caso de los links si queria abrirle en una ventana nueva o en la misma, pero en esta version nada de nada.

    Nose si me he explicado bien y tampoco sé si esto deberia estar aquí, pero la verdad es que no he encontrado ningun foro de soporte en español sobre WP que tenga movimiento.

    Gracias y felicidades por la web.

  2. Hola Ricardo,

    La traducción para WP 2.3 la tienes aquí, para que tengas localizado el asunto.

    En cuanto a lo del editor visual. En versiones anteriores de WordPress la posibilidad de disponer de este editor visual se elegía en las opciones generales de escritura, pero a partir de versiones mas modernas tienes que definirlo en una casilla en tu Perfil del panel de administración. Mira primero ahí a ver si la tienes marcada.

    Si esto no te funciona, prueba con el truco que te indico en este artículo del blog, abriendo el fichero y añadiendo la arroba. Luego debería funcionar.

    Y felicidades por el estupendo portal de MTB 😉

  3. Fernando…. como digo siempre… no hay nada como saber.

    Muchas gracias por tu rapidísima respuesta y por la tan buena explicación.

    El tema del editor visual que era lo que mas me importaba ya está funcionando perfectamente y la traducció al español ya está en marcha.

    De nuevo gracias y decirte que has ganado un nuevo lector en la web 🙂

    Saludos

  4. Pues gracias a ti. Tenemos mucho material pero para no agobiar lo vamos publicando cada día.

    Espero que crezca este blog pues fue una necesidad propia que no encontré y, una vez sintiéndome capaz de ello, la pusimos en marcha Guillermo y yo.

    Si tienes alguna consulta mas ya sabes. Mas adelante haremos un foro pero cuando haya mas lectores 😉

  5. Me acabo de mudar de wordpress.com a un hosting patrocinado. El editor visual no me funciona y he probado lo que comentas, lamentablemente no ha funcionado, de momento tengo que sufrir el html para editar un post, aunque uso también scribefire.

    Si se te ocurre porque puede ser, o que otras cosas probar para arreglarlo te lo agradecería. Mi WordPress es el 2.3 y mi PHP es el 5.2.3.

    Muchas gracias Fernando, por cierto me está siendo muy útil tu blog

  6. Hola Miguel, con la versión 5.2.1 y superiores es precisamente con las que son incompatibles WordPress 2.2 y superiores. Si el truco de este post no te funciona solo te quedarían tres opciones, a saber …

    1.- Hablar con tu hosting por si es un problema de memoria del servidor (pasa a veces), o que te permitan usar una versión de PHP inferior a la 5.2.1
    2.- Utilizar una versión de WordPress inferior a la 2.2 (2.1, por ejemplo)
    3.- Aprender HTML y «disfrutarlo». Evitarás muchos códigos mal insertados que mete muchas veces el editor visual

    No se de mas soluciones, aunque investigaré un poco mas a ver, y si la encuentro la incluiré en este mismo post, actualizando la fecha (ójala)

    Un saludo y gracias por visitarnos 😉

  7. Gracias a ti por tu rápida y concisa respuesta. Pues mi caso es que tengo acceso a mi propia máquina Linux, de la que soy administrador y 100% culpable de la colisión entre versiones de los distintos softwares. No tenía ni idea de que esto fuera así.

    Sobre la RAM estoy seguro de que no es el problema. Así que tendré que probar a cambiar la versión de PHP o bien esperar a que lo corrijan en futuras versiones ¿no?

    Cambiar de versión de WordPress hacia atrás no parece muy recomendable ¿no? Y cambiar la versión de php, creo que ahora que ya está todo configurado sería como volver a empezar.

    En fin que follón, muchas gracias por todo. Estaré atento por si das con algún sistema mejor.

    Un saludo

  8. Ir hacia atrás en WordPress no tiene porque ser malo, solo te pierdes alguna de las funcionalidades, algunas veces no vitales, de las actualizaciones.

    Por supuesto que ir atrás en PHP es mas complicado, y afectaría a otros servicios alojados así que es la peor opción. Te lo decía porque si te alojas en una empresa grande suelen tener varias máquinas con varias versiones y solo tienen que cambiarte de máquina el alojamiento. A mi me ha tocado hacerlo en alguna ocasión y para ellos no supone problema alguno.

    En cualquier caso, si te apremia el editor visual y no te quieres enredar en mas historias prueba esto:

    1.- Quitas la marca de tu perfil de uso del editor visual

    2.- Instalas este plugin. Es bastante capaz, te tienes que acostumbrar a el pero se integra bien y se adapta a otros plugins que te instalan botones en el editor y esas cosas.

    Ahora que me acuerdo, a veces también puede ser problema de la plantilla ¿has probado con otro theme a ver si también te pasa?

  9. Pues acabo de probar con otros dos themes (uno el por defecto de WordPress) y el WYSIWYG sigue sin funcionar.

    No se me había ocurrido pensar que lo del PHP lo decías por lo de las distintos snapshots que tienen de las máquinas las compañías de hosting.

    Lo de ir para atrás, lo decía porque me imagino que entre versiones se corregirán errores de usabilidad y lo que es más importante de seguridad. Prefiero quedarme como estoy de momento.

    La idea del plugin ha sido el toque definitivo, muchísimas gracias por la información porque sin el editor estaba sufriendo como un chino, y aunque sepa HTML, no es lo mismo editar visualmente y puntualmente ver el código, que sufrir tags html sin espaciado…

    Así que mil gracias por el hack, que sepas que agrego tu blog a mi lector RSS.

    Un saludo y sigue así

  10. Me alegro que te valga aunque, como imagino, te quedas como yo con el misterio de ver el problema real.

    Lo que no termino de entender es si tu problema es como la captura de este artículo en concreto o que pusieras lo que pusieras en tu perfil te salía el editor HTML ¿?. Es que cambia la cosa si es de este modo y podría ser una carga incorrecta de la instalación de WP que se podría solucionar subiendo la carpeta tinymce de nuevo.

    Tu dirás.

  11. Hola,
    Despues de actualizar wp a la versión 2.3.2 descubrí que el editor visual no funcionaba. El problema puede estar debido a varias causas. En mi caso era porque uso una version antigua del theme Lowstream (la 2.1.0). Para solucionarlo he copiado el fichero «prototype.jp» de WP (wp-includes/js) al directorio «js» del theme. Con la versión correcta del fichero el editor visual ha vuelto a funcionar.
    Un saludo

  12. Hola, muy buenas. Espero que me puedan resolver el problemilla que tengo, es relacionado con el editor visual… A ver, soy novato en el mundo del wordpress. Instalé la version 2.0.5 en mi pc para hacerme un tema con mayor comodidad que subiéndolo al servidor. Allí (en mi pc), el editor visual funcionaba perfectamente. Cuando terminé el tema, subí el wordpress a mi host y dejó de funcionar el editor visual.
    Buscando información por internet llegué a esta web, y me decidí a actualizarme directamente a 2.3. De nuevo, preferí hacer las pruebas primero en mi propio pc, y todo fue satisfactorio.
    Luego procedí a subir la actualización al host (siguiendo los pasos oficiales del upgrade.php). Una vez más, ‘online’ no me funciona el editor visual. Probé lo que mencionan aquí (la @ delante de la llamada realpath) y no se solucionó.

    ¿Qué me recomiendan?

    Es imprescindible que lo solucione ya que el cliente al que va dirijido el blog no tiene conocimientos informáticos y necesitaría el editor visual.

    Gracias de antemano y un saludo

  13. Si sigue sin funcionar, tambien hay que modificar esto (en el mismo archivo mencionado en el post):

    Busca una linea (es unica) que diga así

    $supportsGzip = true;

    Hay una igual que dice «= false», pero más abajo hay otra que dice «= true». Cuando la encontramos (yo uso Notepad o wordpad así que con Ctrl B busco) cambiamos ‘true’ a ‘false’. Después la subimos otra vez al directorio (obviamente sobreescribiendo) y ya anda.

    1. a mi me pasa que no cuento con esa linea para ser exactos yo trabajo desde ubuntu y me genera otro código el cual se llama wp-tinymce.php es allí donde encontré el comando $path = realpath($path); pero sigue sin funcionar y no localizo el comando que ustedes mencionan para ser mas exactos dejare el código;

      <?php

      /**

      * Disable error reporting

      *

      * Set this to error_reporting( -1 ) for debugging.

      */

      error_reporting(0);

      $basepath = dirname(__FILE__);

      function get_file($path) {

      if ( function_exists('realpath') )

      $path = @realpath($path);

      if ( ! $path || ! @is_file($path) )

      return false;

      return @file_get_contents($path);

      }

      $expires_offset = 31536000; // 1 year

      header('Content-Type: application/x-javascript; charset=UTF-8');

      header('Vary: Accept-Encoding'); // Handle proxies

      header('Expires: ' . gmdate( "D, d M Y H:i:s", time() + $expires_offset ) . ' GMT');

      header("Cache-Control: public, max-age=$expires_offset");

      if ( isset($_GET['c']) && 1 == $_GET['c'] && isset($_SERVER['HTTP_ACCEPT_ENCODING'])

      && false !== stripos($_SERVER['HTTP_ACCEPT_ENCODING'], 'gzip') && ( $file = get_file($basepath . '/wp-tinymce.js.gz') ) ) {

      header('Content-Encoding: gzip');

      echo $file;

      } else {

      // Back compat. This file shouldn't be used if this condition can occur (as in, if gzip isn't accepted).

      echo get_file( $basepath . '/tinymce.min.js' );

      echo get_file( $basepath . '/plugins/compat3x/plugin.min.js' );

      }

      exit;

  14. Gente, pero en la version anterior a la ultima, o sea la 2.3 aun no aparece el editor visual. Incluso he revisado el archivo al que hacen mencion para modificar y dicha linea no aparece. Ademas otras cosas no andan. Creo que lo mejor es subir toda la version de WP otra vez. Esto ultimo si la version del PC funciona bien y subes eso mismo no deberia haber diferencia con la del hosting, o no?.

    Saludos.

  15. Si que puede haber diferencia gonzalo porque tu PC no es el mismo del de tu hosting, pueden variar las versiones de PHP o mySQL, tu PC tiene seguramente mas RAM, los permisos son globales y sin restricciones.

    En tu hosting no gestionas tu el ordenador donde está instalado WordPress 😉

  16. Bueno, lo primero muuchas gracias por las respuestas. He de decir que después de mucho pelearme con el tinymce, instalé por mi cuenta la versión 3.0.5 y funcionaba bien. De todas formas, hace unos dias lanzarón la versión 2.5 final del wordpress, que incluye la 3.0.5 del tinymce, así que «estando a la última» se soluciona todo :D. Un saludo y gracias de nuevo.

  17. No te creas Shalafi porque mucha gente está teniendo problemas con la versión de wp 2.5 y el editor. Eso si, la mayoría de las veces se soluciona vaciando la cache del navegador.

    Nosotros acabamos de actualizar y va perfecto.

  18. Hola.

    En la version 2.5 tambien hay problemas con el editor visual, este no aparece y lo mas curioso (no se si es solo micaso o no) el archivo «wp-includes/js/tinymce/tiny_mce_gzip.php» aparece vacio, no contiene nada. entonces que editamos?. He buscado en wordpress.org, pero nada.

    Saludos.

  19. Hola fernando, te cuento que tengo exactamente el problema que muestras en el post, sin importar que tenga el editor habilitado o deshabiltado. instale wordpress 2.3.3 y hasta ayer funcionaba, hoy ya no, como me aparecía la actualización disponible, la hice y sigue el problema.
    Con respecto a editar el archivo wp-includes/js/tinymce/tiny_mce_gzip.php. lo descargue y aparece vacio, tambien en la versión que baje de wordpress. Entonces copie el que tenía en la versión anterior, lo edité, lo subi pero tampoco funcionó.
    Despues de todo eso, instalé el pluggin que recomendás…. una lástima….
    El problema podrá relacionarse con la memoria cache del servidor o algo así?
    espero que puedas ayudarme, exelente tu blog, saludos.

    PD:Olvidaba decir que actualicé a la ultima version la 2.5. descargada de la web oficial.
    Gracias

  20. Hola Fernando
    Solucioné el problema. Despues de muchas vueltas y seguir el hilo de los foros, pensé en una reforma hecha a mi plantilla de functions.php del template. Borré la función que había agregado (en las anteriores versiones de WP nunca me produjo errores) y apareció el editor..!!!!
    Gracias por tu ayuda. espero que a otro también le sirva mi mala experiencia.
    Vos te darás cuenta porque la función me tiraba error, está relacionada con los enlaces permanentes, por ahí leí tenían problemas con los enlaces y decidí probar, yo no tengo idea..
    la funcón es la siguiente.
    <?php
    function my_content_rss( $text ){
    IF ( is_feed() & !is_404() ){
    global $post;
    $text .= «Enlace permanente: » . wp_specialchars($post->post_title,true) . ««;
    IF ( $post->comment_status == «open» ) $text .= » (Escribir un comentario)»;
    $text .= «.n»;
    $text .= «Leer más: » . get_bloginfo(«name») . «.n»;
    };
    RETURN $text;
    };
    add_filter( «the_content», «my_content_rss» );
    add_filter( «the_content_rss», «my_content_rss» );
    ?>

    Gracias saludos

  21. Hola, tengo un problema con la nueva versión de WP2.5.1

    Antes tenía el editor TinyMCE, pero el que trae por defecto esta nueva versión de WP no me termina de convencer, no es tan completo como esperaba. Así que cometí la osadía de instalarle la última versión del Tiny y…. fracaso total. No salía nada, borré incluso la caché del navegador… así que lo desinstalé. Pero…. ahora no me sale el editor nativo de WP.

    He reconstruido el directorio completo de
    …/wp-includes/js/tinymce , pero sigue igual. ¿Qué está pasando? ¿Qué fichero me modificó ese plugin que ha provocado que el editor nativo no funcione?

    Gracias.

  22. pues ahora tengo yo problemas con el editor visual… intentaba cambiar los permalinks y he dado permisos a index.php (tengo un servidor gratuito en 000webhost que tiene Apache pero no me muestra htaccess) y he podido cambiarlo. No obstante, me he dado cuenta de que el editor visual, que estaba puesto, ahora no sale…sale el html aunq la pestaña del editor visual esta elegida… alguien me puede ayudar???

  23. Hola a todos, tengo el mismo problema con el editor visual mi version de php es 5.2.6 y el de WP 2.04 , la vdd estaba funcionando todo normalmente y solo se ven los botones de las etiquetas del html, y la casilla que esta en usuario –> perfil , para activar el editor esta seleccionado , espero me puedan contestar

  24. Gracias, muchas gracias…
    me salvaste, estuve varios dias sin el editor visual…
    Incluso reinstale varias veces wordpress pensando que ese era el problema…
    Eso que dijiste en el post no me funciono si xD…
    Pero el plugin me sirvió y ahora voi a poder escribir sin ningun problema :B

    Gracias… nos vemos

  25. Disculpa yo tengo un problema similar con el TinyMCE en modo visual solo veo etiquetas html, me gustaria que me dijeras que puedo hacer….

    es desesperante estar usando etiquetas para todo….

  26. Hola! Primera vez por aquí.

    Instalé la versión 2.6.5 en un servidor gratuito (de hecho el segundo que pruebo) y tengo un problema con el editor visual, si bien se ve la solapa Visual, sólo veo los botones correspondientes a la solapa HTML y no se puede cambiar de una solapa a otra.

    De hecho, aunque aparece detenido sobre VISUAL, la edición que permite es de tipo HTML.

    Tengo en un servidor contratado la versión 2.6.3 y no me ha dado problemas, quería probar ésta antes de migrar el blog y noto ese problema.

    ¿Tienes idea de qué está pasando?

    Saludos, Vero

  27. A mi me pasa lo mismo que a ti Vero, y aun poniendo la @ donde se habla de la función esa, no consigo hacer visible el editor.

    Me pasa exactamente lo que describes. :/

  28. Hola Ayuda WordPress, he leido este blog por mas de un año y me han sacado de terribles problemas. Esta vez vengo a dejar un post por que el 4 de diciembre instale la version 2.6.5 de wordrpress y funcionaba de maravilla.

    Pero repentinamente dejo de funcionar el editor visual, me pasa igual que a Vero.

    Ya probe vaciando el cache del navegador, desactivando los plugins y lo que me sorprende es que dentro de la carpeta: wp-includes/js/tinymce/ no encuentro el archivo mencionado: tiny_mce_gzip.php.

    que raro que es este editor visual, he instalado varias veces wordpress y es uno de los problemas mas comunes de wordpress. Espero que me puedan dar una ayudita y los felicito por este blog tan bacano, saludos desde colombia.

    1. Deejay, pueden ser muchas cosas como ya sabes. Prueba a descargar la versión de WP de nuevo y compara los archivos de la distribución y los que tienes en tu servidor. Si ves que hay diferencias soluciónalas. También puede ser la versión de PHP de tu servidor y alguna cosa mas, incluso la versión de flash de tu navegador. Como ves no es algo trivial, aunque si molesto.

  29. En los archivos de mi sitio, no existe el mentado tiny_mce_gzip.php. Uso WordPress 2.7 en español, y la versión de PHP del servidor que utilizo es 5.2.6. Revisé los archivos de la distribución original y se corresponden, probé diferentes plugins pero nada, sigo sin ver el editor visual y ya no se que hacer. Muchas gracias de antemano.

  30. Hola, buenas noches,

    Tras cambiar un WordPress 2.6.2 de un servidor a otro, me quedé sin el editor visual, con una sola linea de herramientas en el editor solo referente a añadir medios y sin poder cambiar a la pestaña de HTML.

    Me ocurre como a Vero y Sebastián. He comprobado contenidos de las carpetas y a parte no tengo el tiny_mce_gzip.php, que imagino será lo normal en esta versión.

    Seguiré probando e investigando y prometo publicar en este sitio de gente tan "apañá" la solución si la encuentro.

    Saludos!

    1. hola

      tengo wordpress 2.8.2 la ultima version en un hosting freehostia. con php version 4

      intente cambiar el theme y no se ve el editor visual.

      la carpeta que dices que hay que modificar no se encuentra

      todavia busco la solucion.

      ayuda porfa

  31. Tengo la versión 2.5.1 de WordPress en mi hosting, no quisiera actualizarla porque tengo miedo que me descontrole muchas cosas de las que ya tengo y me costó organizar. Lo intente en localhost y me paso eso.

    El problema que tengo que cuando le doy añadir una imagen y sale el cuadro de dialogo para subir la imagen y eso, ese cuado de diálogo en internet explorer está más abajo de la pantalla por lo que no puedo ver el botón insertar imagen o borrar y tampoco puedo modificarlo, si me muevo con el mouse se mueve el fondo pero no ese cuadro de diálogo, alguien sabe como solucionarlo? Gracias

  32. MIl GRACIAS.

    actualize mi web de 2.8.4 a 2.8.6 y me havia desaparecido la forma de edicion visial, puse la arroba @ y solucionado.

  33. Pingback: Falla el editor visual de wordpress | Memorias de un Romosoft

  34. Hola, en mi caso no fue error de editar el archivo porque simplemente NO ESTABA, asi que para los que tienen este problema intenten ver si el archivo existe comparando con el que descargaron en su computador, pudo ser error del cliente dtp que no lo subio.

    Saludos.

  35. Hola,

    me he instalado la nueva versión de wordpress, 3.0.1.

    Cuando voy a editar una entrada en la opción VISUAL sólo me aprecern tres iconosde edicion, los usados para cargar video e imagenes. Con lo que no puedo editar el texto sin utilizar el html.

    He seguido los comentarios y he provado alguna de las soluciones. No he encontrado el archivo tiny_mce_gzip.php. y en mi perfil no encuentro tampoco ningún lugar para activar el editor.

    Necesito vuestra ayuda!

    Muchas gracias!

    ¿Alguien me podría ayudar?

    Muchas gracias!

      1. A mí me acaba de pasar. Lo que se recomienda, es DESACTIVAR TODOS los plugins. Es muy muy probable que alguno esté «petardeando» vuestro wordpress. Los desactiváis todos, y mirais si ahora el editor visual se ve bien (a mí, se me veía bien). Después de hacer esto, tenéis que ir activando 1 por 1 todos los plugins y mirando cuál es el que hace que el editor visual no se vea. Una vez lo detectéis, mirad si lo tenéis que actualizar…

  36. No entendí bien que 3 botones del editor visual son los únicos que te aparece. Si puedes especificar.

    Hay un botón que si te paras sobre el dice "ver/ocultar botones adicionales" quizàs es ahì.

    Ese archivo que dices yo no lo tengo, el que tengo es wp-tinymce.js.gz o wp-tinymce.php, y esta bajo la dirección /wp-includes/js/tinymce/ pero no entiendo para que lo quieres.

  37. Asociación Ec

    Bueno, parece que el tema de los novatos y los editores visuales y demás, sigue en boga. El caso es, como a casi los otros, que de un día para otro, se me ha cambiado el editor y no salen ya no los iconos que aprecían antes como: justificar, o ordenar, etcc) y además el texto aparece en html,, del que no tengo ni la más remota idea,. Cuando hice este blog siempre escribía en modo visual y ya. Además a la hora de agregar una imagen le daba al botoncito y se abría la carpeta y ahora no. En fín m,ás de lo smismo. ¿alguna sugerencia? Nuestro blog es: http://www.ecoasios.es

  38. Asociación Ec

    He ido al ftp y ese archivo que comentas no está, en mi sitio es: wp-includes/js/tinymce/tiny_mce.js ó wp-includes/js/tinymce/tiny_popup.js ó wp-includes/js/tinymce

    /tiny_mce.js ó por cierto mi dirección de e.mail es: [email protected]

  39. Txarlieavisos

    Yo tampoco encontraba el archivo citado y al final decidí reinstalar toda la versión WP 3.3.1. Ahora vuelve a funcionar y el tinymce va bien. 

  40. Hola, acabo de actualizar a la 3.3.1 _br y no me sale el visor con iconos de edicion.
    ya re re actualize y lo mismo. y luego otro error que tiro fue el de "fatal error allowed memory size of bytes exhausted". Agradecerè ayuda, pues soy nobato !!!!!

  41. Simplemente hay que limpiar el cache Internet del navegador y listo.
    Yo estaba trabajando cuando colapsó y cuando abrí de nuevo el editor de entradas de WordPress, ya no se veían los botones del editor y traté de hacer varias cosas, pero no funcionó, así que limpié el cache de Firefox y abrí de nuevo el editor y listo, como nuevo je je.

  42. Hola, yo tambien tuve ese problema y la solucion mia fue esta:
    Me fui a los instaladores de plugins de mi word pres y desactive todos los plugins, luego, fui activando uno a uno, hasta que encontre el plugin que creaba conflicto con mi visual de texto, y era el plugin de pop up domination, que lo comrpré y no me ha servido para nada sino para dañarme el blog, como que no es compatible con este ultimo version de wp.Espero les sirva de ayuda mi solucion y gracias al que esc ribe en este blog por darnos mucha informacion.

  43. Hola amigos, ayudawp tiene todas las soluciones posibles en multitud de errores en WP.
    En este caso, yo he probado lo que comentais y no me ha funcionado…
    cierto es que yo utilizo otra versión de WP, en este caso superior (una de las de 3.8 …)
    Sin embargo conseguí solucionarlo instalando el plugin Use Google Libraries.
    Espero que os sirva de ayuda.
    Un saludo.

  44. Me parece que la solución puede ser mas sencilla. En el escritorio wordpress de vuestra web, haceis click en maquetador visual que aparece a la izquierda, bajo de entradas, páginas y demás, y os aparecen unas casillas donde elegiréis las páginas donde queréis que aparezca el editor. Darle a pages y posts. Y al darle a posts ya aparecerá.

  45. Pingback: Mi Lista de lo que debería cambiar en WordPress

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

 

Ir arriba Ir al contenido