WordPress 5.0 y Divi ¿son compatibles?

WordPress 5.0 se ha lanzado hoy, y con él vienen algunos cambios muy grandes.

WordPress 5.0 introduce una experiencia de edición de entradas completamente nueva. Este nuevo editor no sólo reemplaza a TinyMCE, sino también a toda la página de edición posterior.

Para muchos, este cambio puede parecer estridente a primera vista. La buena noticia es que no tienes que saltar de cabeza al nuevo editor.

El editor clásico junto con el Divi Builder clásico todavía están disponibles.

La última versión de Divi es compatible con WordPress 5.0

Las últimas versiones de Divi, Extra, Bloom, Monarch y Divi Builder son compatibles con WordPress 5.0.

Es importante que actualices Divi a la versión 3.18+ antes de actualizar WordPress a la versión 5.0. Esta versión aborda muchos problemas de compatibilidad con el nuevo editor de bloques Gutenberg y te permitirá cambiar del Divi Builder y entrar en el Visual Builder.

Esta actualización también aborda los problemas con el nuevo sistema de cajas meta, que se utilizan para mostrar la configuración de la página Divi y las opciones de formato de postproducción.

Además, se ha ampliado la compatibilidad con formatos de entrada para tener en cuenta los nuevos tipos de contenido de Gutenberg (como bloques de vídeo y audio).

Puedes actualizar tu tema y actualizar tus plugins usando el sistema de actualización estándar de WordPress. También deberás introducir su nombre de usuario y clave de API en los paneles de opciones de temas y plugins.

Si no recibes un aviso de actualización o tienes problemas para actualizar, también puedes descargar las últimas versiones del producto desde el área de miembros y cargarlas manualmente.

Cómo usar Divi en WordPress 5.0

El uso de Divi Builder con WordPress 5.0 es un poco diferente a las versiones anteriores.

Notarás que el diseño general del editor de entradas ha cambiado, y que aparece un nuevo cuadro al crear nuevas páginas que te permitirá elegir entre Divi Builder y el editor de bloques estándar de WordPress.

Puedes cambiar entre los dos en cualquier momento.

WordPress 5.0 elimina el editor clásico, junto con el Divi Builder clásico

WordPress 5.0 reemplaza el editor clásico con una experiencia de edición de entradas completamente nueva.

Junto con la eliminación del editor clásico viene la eliminación de todas las aplicaciones conectadas, como el Divi Builder clásico.

Después de actualizar a WordPress 5.0 encontrarás que el editor clásico y el Divi Builder clásico (también conocido como Backend Builder) no se encuentran en ninguna parte.

Pero no te preocupes, todavía puedes usar el editor clásico y el Divi Builder clásico instalando el plugin Classic Editor. Esto desactivará la nueva experiencia de edición y te permitirá acceder a Divi Builder clásico.

Aún puedes usar el Divi Builder clásico instalando el editor clásico

Si no estás listo para usar el Visual Builder, o si no estás listo para usar el nuevo editor de bloques de WordPress 5.0, está bien. Puedes simplemente instalar el plugin Classic Editor y tu web WordPress y el Divi Builder funcionarán tal como lo hacía antes de actualizar a WordPress 5.0.

Puedes usarlo todo el tiempo que necesites para familiarizarte con el nuevo sistema, y Divi seguirá siendo compatible tanto con el editor clásico como con el nuevo editor de Gutenberg.

Una vez instalado, ve a Ajustes > Escritura y asegúrate de que el editor clásico está configurado como tu editor por defecto.

Otra opción es desactivar completamente el editor de bloques.

Puedes desactivar el nuevo editor de bloques en las opciones de Divi

También puedes desactivar el nuevo editor de bloques de WordPress y activar el editor clásico dentro de las opciones de Divi.

Si estás utilizando WordPress 5.0 o superior, aparecerá una nueva opción en Divi > Opciones del Tema > Builder > Avanzado.

¡Y pronto más compatibilidad aún con WordPress 5.0!

Por ahora Divi se ha centrado en la corrección de errores importantes y en la compatibilidad básica con WordPress 5.0 para Divi y el resto de productos insignia de Elegant Themes, pero la historia no termina ahí.

Ya hay planeadas tres etapas adicionales de compatibilidad para las próximas semanas, y las formas en las que Divi se integra e interactúa con Gutenberg serán más avanzadas y más fluidas en un futuro próximo.

VALORA Y COMPARTE ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
(17 votos, promedio: 4.5)

¿Te gustó este artículo? ¡Ni te imaginas lo que te estás perdiendo en YouTube!

9 comentarios en “WordPress 5.0 y Divi ¿son compatibles?”

  1. Fernando Jiménez

    Gracias F.
    Parece una opción más «limpia» activar Enable Classic Editor en Divi/Opciones del Tema/Builder/Advanced, tal como muestras en la imagen, y así no añadir más plugins.
    Funciona a la perfección.

        1. alexandra sanchez

          Es cierto no se necesita tener instalado el plugin clasicc editor para desactivar el nuevo editor, Muchas gracias por el valioso aporte

  2. Adrian Cuervo

    La respuesta al título debería estar en la primera línea y es: NO. El desarrollo del artículo explica como hacer apaños y «rollbacks» temporales para solucionar que DIVI NO ES COMPATIBLE, hoy, con WordPress 5, de una forma limpia e integrada.

    1. Como la mayoría de plugins que interactúan con el editor a día de hoy: DIVI SÍ ES COMPATIBLE CON WORDPRESS 5.0 pero no aún con el editor de bloques. De la misma manera que la inmensa mayoría

      1. Adrian Cuervo

        Hola Fernando, ahora vamos afinando más el contenido del artículo, gracias. Desde mi punto de vista como usuario de Divi, no se puede afirmar que es compatible, cuando su función principal (crear y editar artículos), es incompatible con la principal mejora de WP 5: el sistema de bloques. Sería como decir que es compatible con el castellano, pero no puede escribir eñes. Hasta tal punto que muchos usuarios recomiendan no actualizar si usas DIVI, y yo lo suscribo.

        1. Te da las 2 opciones, y tampoco hace falta instalar el editor clásico. Al final ha hecho lo mismo que el resto de maquetadores, ofrecerte un modo de usar un editor u otro (bloques o maquetador)

          Y yo no recomiendo actualizar pero en general jaja

          Son demasiadas cosas (plugins, temas) las que no van bien

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

 

Ir arriba Ir al contenido